x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.6 crashing and lost dpi curve

Hi, Devs!

I'm here to report two problems which our team discovered after migration to 4.6.

  • We have comments blocks in blueprints on Russian language. After migration from 4.5.1 to 4.6 we trying to open BP methods with that comments and UE4-Editor crashing. This issue reproducing clearly in blank project.

  • In our project we are using DPIcurve. It's a copy of default project DPI curve in User Interface settings. We need it to work with our own cursor layer (still waiting for your software realization of custom cursors, guys!). After migration, our curve seems like a straight line without any key values. We looked into DefaultEngine.ini and look what we have found inside it right after migration (without any changes):

    ... [/Script/Engine.RendererSettings] .. UIScaleRule=ShortestSide UIScaleCurve=(EditorCurveData=(Keys=((Time=480.000000,Value=0.444000),(Time=720.000000,Value=0.666000),(Time=1080.000000,Value=1.000000),(Time=8640.000000,Value=8.000000))),ExternalCurve=CurveFloat'/Game/interfaces/dpiCurve.dpiCurve')

    [/Script/Engine.UserInterfaceSettings] UIScaleCurve=(EditorCurveData=(Keys=((Time=480,Value=0.444),(Time=720,Value=0.666),(Time=1080,Value=1.0),(Time=8640,Value=8.0))),ExternalCurve=None) UIScaleCurve=(EditorCurveData=(Keys=((Time=480.000000,Value=0.444000),(Time=720.000000,Value=0.666000),(Time=1080.000000,Value=1.000000),(Time=8640.000000,Value=8.000000))),ExternalCurve=None)

We have removed first 2 rules from RendererSettings (obvious it should be placed in /Script/Engine.UserInterfaceSettings) and after restarting our project we have found DefaultEngine.ini like this:

 ...
 [/Script/Engine.RendererSettings]
 ...
 UIScaleRule=ShortestSide
 UIScaleCurve=(EditorCurveData=(Keys=),ExternalCurve=None)
 
 [/Script/Engine.UserInterfaceSettings]
 UIScaleCurve=(EditorCurveData=(Keys=((Time=480,Value=0.444),(Time=720,Value=0.666),(Time=1080,Value=1.0),(Time=8640,Value=8.0))),ExternalCurve=None)
 UIScaleCurve=(EditorCurveData=(Keys=((Time=480.000000,Value=0.444000),(Time=720.000000,Value=0.666000),(Time=1080.000000,Value=1.000000),(Time=8640.000000,Value=8.000000))),ExternalCurve=CurveFloat'/Game/interfaces/dpiCurve.dpiCurve')

It works as we expecting now (our dpiCurve wasn't droped), but I'm aware of duplicated options in DefaultEngine.ini. Probably we'll got some troubles in future about it?

Product Version: Not Selected
Tags:
more ▼

asked Dec 05 '14 at 03:58 AM in Bug Reports

avatar image

Alanir
206 15 22 31

avatar image Alanir Dec 09 '14 at 09:10 AM

UPD:

Problem with crashing have appeared again. If I'm working with userwidget blueprint for long time every compilation will crash UE4-Editor. The only way - remove Saved directory.

avatar image Alanir Dec 16 '14 at 01:36 AM

This crashing is very annoying. I can't just work. Loosing a lot of time.

My version 4.6.0-2369412

Binary version.

Dxdiag in attachments link text

Which information should I provide?

I'm sorry, but I will send every crash report until you will start work with that issue.

dxdiag.txt (34.4 kB)
avatar image Rudy Q ♦♦ STAFF Dec 17 '14 at 06:27 PM

Hello Alanir,

Thank you for the information that you have provided. However, I do have a question for you pertaining to your issue.

Quick question:

I see that you can reproduce this in a clean project. Can you provide us with a detailed list of instructions to reproduce this on our end?

avatar image Alanir Dec 17 '14 at 11:39 PM

There are no clearly steps for reproducnig this bug. I'm just working with UserWidget for a random period and after blueprint compilation (or project playing) it crashes iwth same code. I will give it a try in 4.6.1 and will report you about reproducing.

avatar image Alanir Dec 24 '14 at 03:43 AM

Keeps crashing.

avatar image Rudy Q ♦♦ STAFF Dec 24 '14 at 02:47 PM

Hello Alanir,

Since you are having trouble coming up with a test case that I can use to reproduce this issue, would it be possible to get a copy of a project that you are using that is causing the problem?

avatar image Alanir Dec 26 '14 at 03:32 AM

Hell Rudy,

http://talennsy.org/tmp/debug.zip

Just reproduced in clearly steps in that project.

  • Open UserWidget Content/Game/my/interface

  • Remove HorizontalBox in Root

  • Add Image to Root

  • Add Tooltip to Root

  • Try to compile that UserWidget

  • Crash

avatar image Alanir Jan 12 '15 at 12:36 AM

Are there some news?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Alanir,

I was able to get your project to react the way you said it would. I have written up a report ( UE-7560) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and your information. As a side note, I did find that if the save folder is deleted the project will not crash.

Make it a great day

more ▼

answered Jan 14 '15 at 06:30 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Alanir Jan 15 '15 at 01:10 AM

Hello Rudy,

What about dublication in configuration files?

avatar image Rudy Q ♦♦ STAFF Jan 15 '15 at 08:55 PM

Hello Alanir,

After looking into the duplication of the configuration inside the Engine.ini, it does not appear that it will cause any issues.

avatar image Alanir Jan 15 '15 at 11:28 PM

But is that ok? Will it be fixed? I'm totaly convinced that such sort of "mistakes" will hit your from the back in future. So, I don't want to think about it when I'm diging some current problems in the future.

avatar image Rudy Q ♦♦ STAFF Jan 16 '15 at 03:49 PM

Hello Alanir,

It was reported and sent to the developers for further consideration Along with the other issue. The specific report number is UE-7681. Just as with the other issue I will provide updates with pertinent information as it becomes available.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question