x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Demo Recording 4.6 - Crash on playback

link textHey there,

I get crashes upon trying to playback demo's, using the new feature from 4.6. Even on the shootergame.

Using the console in-game, i type in: "demorec test"

Then

"demoplay test"

Then the editor just closes with a error report. (submitted)

Also, is there not a stop recording function? How are we meant to tell the engine to stop recording?

Will it instantly stop if i jump out of the editor?

Is anybody else able to re-produce this issue?

Thanks, really looking forward to testing this feature!

Product Version: Not Selected
Tags:
logs.zip (52.9 kB)
more ▼

asked Dec 05 '14 at 03:04 PM in Bug Reports

avatar image

Tesla
21 3 6 7

avatar image Vormulac Dec 09 '14 at 07:39 PM

I've got the same thing happening on my end. I've tried it in a packaged version of shootergame as well and ran into the same issue. In the packaged game this is what get's spit out by the error reporter.

 Assertion failed: RemoteRole == ROLE_Authority [File:D:\Unreal\UnrealEngine\Engine\Source\Runtime\Engine\Private\Actor.cpp] [Line: 2278] 


I'm building from source using the release branch from github.

avatar image Rama Dec 17 '14 at 03:02 PM

Standalone

Can you do demos in standalone?

I had no problems creating and playing a demo using commandline version of the game (editor never opened)

Rama

avatar image Vormulac Dec 19 '14 at 09:59 PM

I'm not quite sure what you mean but I've tried in editor (with and without Run Dedicated Server checked), out of editor on a dedicated server and locally (no server).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Tesla and Vormulac,

Sorry we didn't see this earlier. I was able to reproduce this issue in 4.6 and have entered a bug report for it [UE-6477]. I will let you know here when I see any update on it. In the meantime, I will see if I can find some answers regarding how to properly use the feature, as we don't have documentation for it just yet. Thanks for the report!

more ▼

answered Dec 09 '14 at 10:09 PM

avatar image Vormulac Dec 09 '14 at 10:27 PM

Awesome! Thanks Ben. Just one of the many reasons I love you guys.

avatar image abhisheksagi Jan 23 '15 at 11:24 AM

Any update on this? I am trying on 4.7.1 Preview 4 and even with Shooter example it crashes the engine when I type "DemoRec test" and then type "DemoPlay test" -> Demoplay causes the crash

avatar image Ben Halliday STAFF Jan 23 '15 at 08:02 PM

Unfortunately not yet. The bug has not been fixed internally, but it is currently slated to be fixed in 4.8 if possible. I expect proper documentation to follow, but sometimes that takes a bit longer. In the meantime, we are not certain what causes the crash for some projects and not for others. I will post here as soon as I see any update. Thanks for your patience!

avatar image Kory Dec 01 '15 at 04:21 PM

Still exists in 4.10.0 because AuthGameMode is nullptr in the InitListen in UDemoNetDriver

avatar image Ben Halliday STAFF Dec 01 '15 at 06:01 PM

Yea, the bug is still open for investigation. I've bumped the community interest on the report and added your notes, Kory. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question