x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

(UE-4.6 only) Extreme editor lag and mouse jitter while persona is undocked

  • Editor: UE-4.6.0

  • System: MacBook Pro Retina, Mid 2012, 16GB, OSX 10.10.1

  • Problem: Extreme editor lag and mouse jitter while persona is undocked

Starting with brand new project, I got up to step 4 (Intro to Persona) of the Getting Started: Introduction to Blueprint 3rd Person Game Creation" tutorial when both the UE editor's viewport and all UI elements started lagging badly.

I turned all the performance options down and restarted UE4. After restarting, UE4 ran as smooth as glass (about 60 FPS) until I double clicked on the "Idle" animation in the content browser (which opens the Persona tool in a new window per tutorial step 4), at which point the UI lag and mouse jitter returned.

After playing around, I found that docking the Persona window made the problem instantly disappeared (back up to about 45 FPS).

I started with a clean project (per the tutorial), but if you can't reproduce this easily, I'll erase my preferences and take it step by step to see what else might be involved.

Note: I said this was UE-4.6 only because I use multiple monitors and I've never seen a problem with undocked windows until now, BUT, I've also never used Persona until now so this COULD be present in older versions as well.

Product Version: Not Selected
Tags:
more ▼

asked Dec 05 '14 at 04:15 PM in Bug Reports

avatar image

tadmuck
1 2 4 6

avatar image frezer748 Dec 27 '14 at 05:56 PM

Hey everybody,

I have the same problem since updating to 4.6.1, in the previous versions of ue4 I hadn't any lagg problems, but now when I fly around in the editor everything is lagging and I get like 10 fps. The game itself runs pretty smooth.

avatar image frezer748 Dec 27 '14 at 06:07 PM

So I got the editor work more smooth now just by enabling full screen Window>Enable Fullscreen (Shift+F11). Not sure if you mention this trick in the other answers, but I didn't grap it out there. But I still hope the "bug" is getting fixed in the future. Have a great day! :)

avatar image Steve Hardister ♦♦ STAFF Dec 30 '14 at 06:28 PM

Thanks for your feedback. Enabling full screen is what I meant in the answer below where I mentioned "as your gpu has to render the contents of both windows." -I can see how this isn't explicitly clear that in that case you should have one full screen window open instead of in the background with a floating window in front. As far as the other fps drop, it has been included in the JIRA report mentioned below [UE-6354]

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi tadmuck,

It is expected behavior to see a frame rate drop when you have the editor in the background and an a separate Persona window floating in the foreground as your gpu has to render the contents of both windows. Docking the window and seeing the increase back to only 45fps is expected as the animation is being rendered in real time in the Persona window.

However, when you switch tabs to bring editor back to the foreground and the Persona window is running in the background, the frame rate should return to around 60fps. When reproducing your issue I found this was not the case in either the OS X or Windows environment. Subsequently I've entered the following report [UE-6354].

When this issue is addressed in a future build an update will be added to this post. Thank you for bringing this issue to our attention.

more ▼

answered Dec 05 '14 at 10:13 PM

avatar image tadmuck Dec 05 '14 at 11:21 PM

Based on what you found, I went back to look a bit closer and I don't think the problem is really an "fps" issue. It really seems like a problem with input/mouse event handling.

If I maximize the graphics paramters to exaerbate the problem, I get about 10-15fps with the Persona window undocked, but it's almost the same with Persona window docked, but there's a HUGE difference in the mouse event handling.

With the Persona window undocked, the frame rate seems to stay around 15fps, but the the viewport "jitters" and lags behind the mouse input. The same lag can be seen when moving the mouse up down over fields in the user preferences (while the Persona window is undocked).

With the Persona window docked (remember that I've turned the graphics way up), the frame rate is still around around 15fps, but it's not really noticeable as a problem because the UI events are in sync with the display. I.e. there's no jitter or lag.

avatar image tadmuck Dec 05 '14 at 11:25 PM

Just to be clear... the input event lag I'm talking about with the Persona window open is really bad... sometimes as much as a second, which makes navigating really bad.

On the bright side, however, this really does go away when the Persona window is docked or closed.

avatar image Steve Hardister ♦♦ STAFF Dec 08 '14 at 07:44 PM

Hi tadmuck,

I've been unable to reproduce your initial issue. Can you please provide a step by step description on how to reproduce this issue. Also, can you provide your processor type and monitor size (ie. i7 / 15" Retina). -Thanks

avatar image tadmuck Dec 08 '14 at 10:53 PM

Hi Steve,

Even though the frame rate doesn't change, I'm convinced that this is just a performance issue as you mentioned previously. When both windows are rendering, the UI lags, but I think that's to be expected. It simply threw me because I wasn't seeing an actual "fps" change.

I'm marking this answered - and thanks!

avatar image Steve Hardister ♦♦ STAFF Mar 27 '15 at 06:46 PM

This has been reported fixed in CL2482969 which will be included in an upcoming release in the near future. If you are still experiencing this performance issue after that point, please let us know by updating this thread.

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question