x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.6 Remote Build for iOS issue with mobile provision after upgrade.

Just a quick background. I have a c++ iOS project that I have successfully build/deployed from a PC using the RemoteBuildTool on an iOS machine since version 4.2. I understand all of the complicated setup necessary since I have been upgrading it all the way to 4.5. Now I just upgraded it to 4.6 by creating a new c++ project so I could use the Import Mobile Provision/Certificate options available.

I'm able to build it remotely but when it gets to the mobile provision part it goes bad. Please take a look at the log file and help me determine what may be missing and what I might be able to do to fix it. Thank you SO much for your time!

http://1drv.ms/1ymHY95

  • jv

Product Version: Not Selected
Tags:
more ▼

asked Dec 05 '14 at 05:10 PM in Packaging & Deployment

avatar image

jeffvoigt
423 19 34 61

avatar image jeffvoigt Dec 05 '14 at 05:48 PM

Update.

It was this line that did not work:

[2014.12.05-16.23.04:015][981]MainFrameActions: Packaging (iOS): UnrealBuildTool: ... 'D:\UE4\UnrealEngine\Engine\Build\IOS/NotForLicensees/UE4Game.mobileprovision' -> '........\\Engine\Intermediate\IOS-Deploy\ciicharm\Shipping..\XcodeSupportFiles\APPDEV7_UE4Temp.mobileprovision'

There was no UE4Game.mobileprovision file in the following directory: D:\UE4\UnrealEngine\Engine\Build\IOS\

I'm not sure how it is supposed to get there but I manually copied my mobile provision to that directory and renamed it to match UE4Game.mobileprovision. Now I'm stuck on the next error. Apparently it doesn't have the right values in it as you can see here:

http://1drv.ms/1s2i5ZX

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi jeffvoight,

Are you still seeing this issue? Have you updated to the newest version of the editor? We are at 4.7.5 now.

more ▼

answered Apr 09 '15 at 09:30 PM

avatar image jeffvoigt Apr 09 '15 at 09:31 PM

I do not have the issue. Everything was fixed. I don't recall what it was that fixed it though.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question