x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Startup map settings?

Hi there,

I'm setting my startup map to be a map I created called Terrain, like this in the "Project Settings":

alt text

When I package my game for OSX, the game crashes, and I get the following in the log:

[2014.03.21-14.51.46:372][ 0]LogLinker:Warning: Can't find file '/Engine/Maps/Entry' [2014.03.21-14.51.46:372][ 0]LogUObjectGlobals:Warning: Failed to load '/Engine/Maps/Entry': Can't find file '/Engine/Maps/Entry' [2014.03.21-14.51.46:372][ 0]LogMac:Error: appError called: Failed to enter /Engine/Maps/Entry: Failed to load package '/Engine/Maps/Entry'. Please check the log for errors. [2014.03.21-14.51.57:915][ 0]LogMac: === Critical error: ===

It would seem that the entry map was not packaged, I take it because it's not used. If i build with the entry map set in those fields, everything runs fine and I can then bring up the console and type Open Terrain.

In Saved/Config/CleanSourceConfigs/Engine.ini, I have the following:

Launch]

[/Script/EngineSettings.GameMapsSettings] EditorStartupMap=/Engine/Maps/Templates/Template_Default GameDefaultMap=/Engine/Maps/Entry ServerDefaultMap=/Engine/Maps/Entry GlobalDefaultGameMode=/Script/Engine.GameMode GlobalDefaultServerGameMode=/Script/Engine.GameMode LocalMapOptions=

In Saved/Config/MacNoEditor/Engine.ini is empty.

I am expecting the game to launch with the map I have specified in the project settings.

Product Version: Not Selected
Tags:
more ▼

asked Mar 21 '14 at 02:59 PM in Bug Reports

avatar image

TommyBear
399 19 31 238

avatar image TommyBear Mar 24 '14 at 02:52 AM

Anyone? Is this expected behaviour?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

TommyBear,

The project settings will only write to your personal local run-time generated INI file, which means that those settings will only apply when running the project directly from your local folder. When you package your project, your local run-time settings will be ignored, and only the project's default settings will be used.

To make your personal settings the default for your project, please click the "Save as default" button. The DefaultEngine.ini file that is included in your packaged project should then have the desired startup maps.

I will make a usability pass on the Settings UI this week to make the distinction between personal settings and project default settings, as well as their relationship to project packaging more clear. Sorry for the confusion!

more ▼

answered Mar 24 '14 at 05:22 AM

avatar image TommyBear Mar 24 '14 at 05:27 AM

Aha!!! Thank you so much for the explanation! It's juat not intuitive at the moment, that's all. Thank you for working on this kind of stuff.

avatar image gmpreussner STAFF Mar 24 '14 at 05:27 AM

For clarification, because this may be of general interest: Unreal Engine uses a so called INI stack, which is a collection of configuration files that will be applied one after another in order to generate the final settings. A stack for system XXX (where XXX can be 'Engine', 'Editor' and other things) typically includes:

  • BaseXXX.ini (applies to all projects)

  • DefaultXXX.ini (default settings for your project)

  • XXX.ini (local run-time generated settings)

XXX.ini will be ignored when packaging, because these are your personal settings for testing/experimenting on your local PC.

avatar image setteventi Sep 28 '15 at 03:36 PM

Hi! where I can find the "Save as default" button. I have 4.9.1 version. Thanks!

avatar image Ben Halliday STAFF Sep 28 '15 at 09:06 PM

Hi setteventi,

For Editor Preferences, it's here:

alt text

Project Settings update the appropriate .ini file instantly.

setasdefault.png (30.4 kB)
avatar image setteventi Sep 29 '15 at 01:49 PM

Thank you!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question