x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Landscape material turns default gray despite shared assets

So, I made a huge landscape material a while back whit 4x4 texture atlases and 5 maps for each material layer within it. It always worked great but now that the shared assets feature have been released as of 4.6 I figured I might as well dismantle my atlases and rid myself of some instructions by just using shared assets instead. However, as soon I try this, landscape components turn default gray checker material like it used to when too many texture samples were used.

Any idea what I might be doing wrong? All textures are set to Shared: Wrap

Product Version: Not Selected
Tags:
more ▼

asked Dec 05 '14 at 10:56 PM in Rendering

avatar image

Sitrec
313 21 23 22

avatar image Sitrec Dec 07 '14 at 08:59 PM

For some reason, when I unplug roughness the problem goes away. I can't use material layers with roughness anymore. Any ideas?

avatar image Adam Davis STAFF Dec 09 '14 at 06:36 PM

Can you show me a screenshot of your material? Additionally, does this occur in a clean project with no additional content?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, I managed to solve it, one of my texture samples was set to the wrong sampler type and I didn't get an error about it, which is weird.

more ▼

answered Dec 10 '14 at 08:31 PM

avatar image

Sitrec
313 21 23 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question