x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Where has the Environment Query object gone?

It used to be under the miscellaneous menu accessed by right clicking in the content browser, but now I can't find it.

Product Version: Not Selected
Tags:
more ▼

asked Dec 06 '14 at 02:24 PM in Using UE4

avatar image

Asher S Einhorn
569 89 73 173

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It's still there, provided you have EQS enabled in Editor Preferences' experimental section.

Cheers,

--mieszko

more ▼

answered Dec 06 '14 at 04:07 PM

avatar image

MieszkoZ STAFF
6.9k 220 41 392

avatar image Asher S Einhorn Dec 07 '14 at 02:08 PM

But it's not in the experimental section. Am I being incredibly blind? alt text

capture.png (34.6 kB)
avatar image MieszkoZ STAFF Dec 07 '14 at 02:09 PM

Which UE4 version are you using?

avatar image MieszkoZ STAFF Dec 07 '14 at 02:15 PM

This is from 4.6

avatar image Asher S Einhorn Dec 07 '14 at 06:52 PM

version 4.5.1

avatar image MieszkoZ STAFF Dec 07 '14 at 07:02 PM

EQS is not officially available in 4.5.1. The only way you can enable it pre-4.6 is to add the following line to your DefaultEngine.ini

 [EnvironmentQueryEd]
 EnableEnvironmentQueryEd=true
avatar image intoxicat3 Nov 14 '17 at 07:16 PM

How to enable EQS in .ini @ 4.18? Above solution isn't working. I would like to commit EQS enabled to everyone.

EDIT: it's working but editor setting is still showing EQS disabled in experimental tab.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question