x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.6 Material Simple drawing wrong position on Mobile Device

Environment: UE 4.6.0, Developing on Mac for mobile, Blueprints

Using "Draw Material Simple" node in blueprint on HUD draws correctly for Mobile Preview. When viewing on mobile device (iPhone 5S tested), it appears to make the 0 position of the Y coordinate at the bottom of the screen.

Note the ScreenX and ScreenY variables were set from the Size X and Size Y of the Event On Draw HUD.

Note...Mobile Preview is good. Mobile Device is not. Using the same math (see in blueprint), it draws a Text, "Shields" in the correct position on device. Also, textures appear to draw in correct position. I have only found bug with Draw Material Simple (using the M_HUD_HEALTH_BAR material from the Example Contents)

Health Bar and Text (Shields) should both be at the bottom of the screen: Size Y - 25.

Please see screenshots: Blueprint alt text

Mobile Device alt text

Mobile Preview alt text

Product Version: Not Selected
Tags:
more ▼

asked Dec 07 '14 at 07:52 AM in Bug Reports

avatar image

ByronBBB
27 3 5 12

avatar image [Epic] Gribbs ♦♦ STAFF Dec 09 '14 at 04:45 PM

Howdy ByronBBB,

Thank you for reporting this issue. I am going to need a bit more information from you on this issue. I have attempted a repro of this issue and have been unsuccessful so far. Would you able to clarify which device you are using to deploy this project to? Is there a quick way using template project where i may be able to reproduce this issue? Also, Would you be willing to provide more photos or even the project so that I may be able to reproduce this issue internally? You can send them to me in a private message in the Forums here: https://forums.unrealengine.com/member.php?4890-Sean-Gribbin

Any additional information would be greatly appreciated

Thanks and have a great day!

avatar image ByronBBB Dec 10 '14 at 06:48 AM

Hi Sean, Yes. Let me try to get a template project demonstrating this tomorrow.

Byron

avatar image [Epic] Gribbs ♦♦ STAFF Dec 16 '14 at 03:42 PM

Howdy ByronBBB,

Just wanted to check in with you and see if you had a chance to create a project that can replicate the issue that you have been seeing. No rush on it if you have not.

Thanks!

avatar image ByronBBB Dec 18 '14 at 06:23 AM

Sean, Yes, still have the issue. Sorry haven't gotten code for you yet.

avatar image [Epic] Gribbs ♦♦ STAFF Dec 18 '14 at 04:21 PM

No worries Byron. Just wanted to be sure that the issue still exists. I am going to give this repro another try later today.

avatar image [Epic] Gribbs ♦♦ STAFF Dec 18 '14 at 04:24 PM

Do you happen to have an anchor set for that section of your UMG?

avatar image ByronBBB Dec 18 '14 at 04:35 PM

Looking at the screenshots above, there isn't a UMG widget displaying on the screen. So, I'm not sure how an anchor would be set. I do use UMG to display the Pause menu when you tap the Pause button (top right), but the button is drawn through HUD. I also come into this map from a screen that had UMG widget displayed, so that may be part of it as well.

I think it is the Draw Material Simple node that is the problem when drawing the HUD. It displays normally (Y = 0 is at the top of the screen) in Mobile Preview, but backwards (Y = 0 at bottom of screen) on Mobile Device.

Thanks! Byron

avatar image [Epic] Gribbs ♦♦ STAFF Dec 18 '14 at 04:38 PM

Sorry about that. I misread a line.

avatar image ByronBBB Dec 22 '14 at 12:46 AM

Hi Sean,

I have created a demo project and been able to reproduce this problem there.

To be perfectly clear (because I was thinking the problem was fixed), the Draw Material Simple node of the HUD works fine when playing on the Mobile Preview, but when you play it on an iOS device (iPhone 5S in my case), the Y coordinate switches to the bottom of the screen.

I'll be glad to send you a link to the project on Dropbox if you can let me know how to PM it to you.

Best regards, Byron

avatar image [Epic] Gribbs ♦♦ STAFF Dec 22 '14 at 03:50 PM

Hey BryonBBB

Thank you for taking the time to create a project in which this issue occurs. You can send me a private message via the Forums. Here is a link to my personal profile: https://forums.unrealengine.com/member.php?4890-Sean-Gribbin . You can just link to there in a message and I will begin looking into the issue.

Thanks and have a great day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Howdy ByronBBB,

Thank you again for sharing a test project with me via the forums. I have tested out this project and have been able to see the error that you have been talking about. I have also tested this issue out on a newer promoted internal build and the issue is no longer occurring. I am unsure as to when this fix will be implemented into a release build but the issue is no longer occurring. I will be sure to revisit this thread when i know more information.

Thanks and have a great day!

more ▼

answered Dec 23 '14 at 10:29 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question