x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Not UE4-specific] UE4.sln crashes Visual Studio Community 2013

As you can read in the replies, this is a VIsual Studio bug and not specific to UE4. Sorry for not testing this first.

So I've installed Visual Studio Community today and I've cloned the Github Promoted branch today. I have not done any modifications whatsoever to the Engine code.

After executing the Setup.bat and the GenerateProjectFiles.bat files I tried to open the UE4.sln file as pointed out in the documentation/wiki.

This opens Visual Studio as expected but after 1-2 seconds the software crashes and it tries to either restart or simply shows an error message that it has been closed, see
alt text The restart seems to be quite useless as when I click on UE4 it crashes again.

I've also reported this on Microsoft's Visual Studio fedback platform but they can't quite help me as the UE4 engine repo is private.

I've tried both with the Master and the Promoted branch. I have no other PC to test this with. The 2 generated sln files (Can't upload these to the answerhub)

Dxdiag.txt
Running Visual Studio Community 2013 Version 12.0.31101.00 Update 4 with all updates installed.

Video of the crash: http://youtu.be/wFZ4tosQznI

Product Version: Not Selected
Tags:
dxdiag.txt (76.4 kB)
more ▼

asked Dec 08 '14 at 02:55 PM in Installation & Setup

avatar image

Moter8
47 10 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Can you try if it happens to diffrent VS project? BEcause it should more like VS problem

more ▼

answered Dec 08 '14 at 03:07 PM

avatar image

Shadowriver
37.3k 936 172 1116

avatar image Moter8 Dec 08 '14 at 03:17 PM

Woops yep, seems like it is a VisualStudio-only problem. I cloned https://github.com/ShareX/ShareX and opened the ShareX.sln file and VIsualStudio crashed too. :<

avatar image Shadowriver Dec 08 '14 at 05:39 PM

Ok then maybe try reinstalling VS :p Or try installing VS Express

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question