x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Build light only not working

Hi I am having problem with build lighting only in ue4 it does not let meet select it all all whenever I add any light into my scene and even build all has no effect on my scene. I can not ad any lighting into my scene as it will not build, I have tried the sample levels and they work perfectly no problems at all it is only on my scene it is not working.

alt text

Product Version: Not Selected
Tags:
screenshot (1).jpg (941.8 kB)
more ▼

asked Dec 08 '14 at 03:23 PM in Rendering

avatar image

harjm
1 1 2 2

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hey Harj

I found a possible solution to the problem.

In your Unreal Projects folder look for the Config folder and open your Default Engine.

Scroll down to [/Script/Engine.RendererSettings] and then look for r.AllowStaticLighting=True It should be set to true not false, I tried it and got the same result. Strangely that option isn't in another project of mine :/

Hope that helps ^_^

more ▼

answered Dec 11 '14 at 10:54 PM

avatar image

Livingdeadjedi
31 2 3 5

avatar image harjm Dec 15 '14 at 11:31 AM

Thanks Livingdeadjedi that worked perfectly I can now build my lighting.

(comments are locked)
10|2000 characters needed characters left

Hi Harjm,

Is this only happening in the project or any project that you've created?

I've not been able to reproduce this on my end. Can you try a couple of things to see if this helps?

  • Under Build lighting, are you able to set the light build quality? If so can you change the quality from preview to medium as a test. Then instead of hitting the option for "build lighting only" hit the Build button in the tool bar where the drop down starts. This should start the build lighting process.

  • Can you try starting a new project, anything really, and see if you have the option and can build lighting in one of those (the starter templates work good for this since everything is already set up)?

If that doesn't solve the issue let me know and we can try some other things.

Thank you!

Tim

more ▼

answered Dec 09 '14 at 05:16 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 98 874

avatar image harjm Dec 09 '14 at 05:23 PM

Hi Tim thanks for replying and have tried what you said but it still does not let me build any lighting and it works perfectly in a new project and the starter templates just my scene it is happening with.

avatar image Tim Hobson ♦♦ STAFF Dec 09 '14 at 05:35 PM

Okay. That's good to know.

Can you open your projects folder (typically in Documents > Unreal Projects > Your Project) and delete the Saved and Intermediate folders? Make a backup if you need or if you have edited any of the config.ini files in here. More than likely something may have gotten corrupted or wrongly set in the ini files and this should reset everything.

Give that a shot and let me know. :)

Tim

avatar image harjm Dec 09 '14 at 05:51 PM

Just tried it deleted the folders but still does not let me build lighting

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question