x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Multiple errors compiling Promoted/Master branch, Windows x64

Git fetch and pulled both branches today (in separate folders), ran the setup.bat on both and the GenerateProjectFiles.bat too of course. Can't get any to compile correctly. UE4Editor does not get compiled, some other stuff does (CrashReportClient.exe, ShaderCompileWorker.exe and related exes, UE4Gamer.exe)

Using the Developement Target and Win64 platform.

Latest Master Branch I tried to compile: https://github.com/EpicGames/UnrealEngine/commit/fe4392fae75f52e566cf415a2282b096dd96af8e

Tried to compile the Promoted branch too and got this; I think both branches output the same errors:

 Error    1    error LNK2019: unresolved external symbol "bool __cdecl PreprocessShaderFile(class FString &,class TArray<struct FShaderCompilerError,class FDefaultAllocator> &,class FString const &)" (?PreprocessShaderFile@@YA_NAEAVFString@@AEAV?$TArray@UFShaderCompilerError@@VFDefaultAllocator@@@@AEBV1@@Z) referenced in function "bool __cdecl CCT::Preprocess(class FString const &,class FString &)" (?Preprocess@CCT@@YA_NAEBVFString@@AEAV2@@Z)    D:\Github\UE4.6-Promoted\Engine\Intermediate\ProjectFiles\Module.CrossCompilerTool.cpp.obj    CrossCompilerTool

 Error    2    error LNK1120: 1 unresolved externals    D:\Github\UE4.6-Promoted\Engine\Binaries\Win64\CrossCompilerTool.exe    1    1    CrossCompilerTool

 Error    3    error : Failed to produce item: D:\Github\UE4.6-Promoted\Engine\Binaries\Win64\CrossCompilerTool.exe    D:\Github\UE4.6-Promoted\Engine\Intermediate\ProjectFiles\ERROR    CrossCompilerTool

 Error    4    error MSB3073: The command "..\..\Build\BatchFiles\Build.bat CrossCompilerTool Win64 Development" exited with code -1.    C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets    38    5    CrossCompilerTool

 Error    5    error : UnrealLaunchDaemon does not support the Win64 platform.    D:\Github\UE4.6-Promoted\Engine\Intermediate\ProjectFiles\EXEC    UnrealLaunchDaemon

 Error    6    error MSB3073: The command "..\..\Build\BatchFiles\Build.bat UnrealLaunchDaemon Win64 Development" exited with code -1.    C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets    38    5    UnrealLaunchDaemon

 Warning    7    The referenced component 'RPCUtility' could not be found.     iPhonePackager


These both are errors from the master branch, about 5 hours apart from eachother. I've cleaned the solution inbetween the attempts. alt text alt text

Dxdiag.txt, Win8.1 x64 running Visual Studio Community 2013 Update 4.

Product Version: Not Selected
Tags:
dxdiag.txt (76.4 kB)
more ▼

asked Dec 08 '14 at 08:20 PM in Installation & Setup

avatar image

Moter8
47 8 10

avatar image Moter8 Dec 12 '14 at 06:00 PM

Bump, still getting some errors and UE4Editor.exe does not get built with Development selected:

When compiling Development Server and Development Client it does compile the Editor binary but outputs similar errors too.
Trying to compile master branch ed1151c80b338ffbc0fb2a9f9a467a5bc027df4f.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

have you tried to compile in "Development Editor" mode?

more ▼

answered Dec 09 '14 at 12:00 AM

avatar image

ScottSpadea
9.5k 317 202 449

avatar image Moter8 Dec 12 '14 at 06:03 PM

Welp I did, that works. But Development should compile right too :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question