x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Blender] Impossible to get animated rig "working" inside UE4 [SOLVED]

[SOLVED] Will post a video tut when i have time about how. Main problem was not having ref 0 enabled.

Hi,

This is exporting from blender -> fbx -> into UE4 I'm having trouble getting any kind of simple rig on a simple model to work proper in UE4. Ive checked many things, my bone scales are 1,1,1. I have applied the scales on everything My animation is simple and starting from 0 to 30 frames. But once i try to import it i get the following bugs.

(Btw i do not get any errors from UE4. The import just goes wrong as follows:)

It looks as if my UE4 is thinking that my model is bigger then it really is. Its hard to find it in the 3d model viewer inside UE4 because i need to zoom in all the way because again. Its counting allot of empty space as my model. Which its not.

Then when i put the model inside my game. It lays on its back and is tiny. But when i have it play an animation. It suddenly grows into a huge model. that "does" play the animation.. Ive been messing with this for.. like from 9 till 8.. and i'm getting a bit fed up now to be honest :P

I really don't wanna go back to Unity just because i cant import any models.

alt text alt text alt text alt text alt text

Product Version: Not Selected
Tags:
more ▼

asked Dec 12 '14 at 09:14 AM in Using UE4

avatar image

VRF
21 2 6 7

avatar image Adam Davis STAFF Dec 12 '14 at 08:53 PM

Hi VRF,

Have you made sure to set the blender scale to uu instead of the standard blender scale? Additionally have you made sure to only have one root bone?

avatar image VRF Dec 14 '14 at 02:41 AM

Yes i have even matched the scale with the HeroTTP .fbx file just to make sure orientation and scale were correctly. And yes i have only one root bone.

actually ended up using same model just redoing things. just seems that it keeps the same bounding box as first scale. but when animation applied it shrinks it down by perhaps a 100 factor. it looks as if the animation does not export with its scale. errors seem to have become less though for some magical reason.

samescaleetc export import info when static when playing animation

avatar image Adam Davis STAFF Dec 16 '14 at 06:53 PM

Is there anything in the animation itself that may be affecting the scale? I haven't been able to repro this on my end, are there any steps you can think of that I can take to see these results?

avatar image EroDera Feb 17 '15 at 01:35 PM

Hello VRF

Unfortunatelly I have the same problem aswell. Would pretty much apprechiate info about your solution. Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This is the process I take to make sure my rigs work correctly: 1. Set your scenes units to metric with scale of 1 2. Import your model into blender (unless you already have one made in blender) 3. Add 1 bone enter edit mode 4. Scale and rotate bones to the correct size while in edit mode if you have the wrong scale or rotation on your bones in edit mode they will reflect that in ue4 but not blender(this step can make or break a proper bind to your mesh) 5. Once you have your rig to the correct size and rotation within edit mode, it's then time to bind your rig to your mesh, next enter object mode, and select your mesh and rig and hit ctrl+p bind with automatic weights 6. Fine tune with weight painting where necessary 7. Select your rig go into pose and select each bone, enter object mode and select the rig and mesh 8. Export fbx with following settings: only settings that need to be changed from the default are Z up and the forward axis should match which direction your rig and mesh are facing, check "selected objects", highlight mesh and armature set scale to 1 9. Hit export 10. Go into your project's content browser make a new folder that represents your animations 11. Click import and and select your fbx 12. I don't change any of the default settings when importing (I don't use toa ref pose) hit import all 13. Cheers you now should have a working skeletal mesh or rig or both

Hope this helps :)

more ▼

answered Mar 01 '15 at 07:23 PM

avatar image

StevenShortridge
26 1 2 5

avatar image EroDera Mar 02 '15 at 12:13 AM

Hello Steve, I have already solved the problem myself as mentioned before(I use rigify, when i generated the rig scaled it properly and applied scale, it was not respected while importing. I solved it by matching scale to UE4 before generating rig, than exporting at scale 1). But thanks anyway, your summary workflow is helpfull list of things good to keep in mind. Happy blending :)

avatar image kusogaki77 Jul 26 '15 at 06:14 AM

StevenShortridge, running UE4 4.8.2 and Blender 2.75, your steps worked for me.

Slight thing I changed was Blender's Scene measurements. I tried setting it to 1, but the mesh was huge. Trying to scale it down wasn't working as expected using the scale widget, so instead I set Blender Scene measurements to .01 (as this guy recommends https://www.youtube.com/watch?v=aC1_m0VdKIY ). Following all the other steps you indicated, everything turned out perfect.

The rig used was created using the Pitchipoi rigify addon.

Thanks to the OP for starting the thread and clearly stating the problem and the fix. And thank you very much for taking the time to write your fix out, StevenShortridge. Much appreciated...!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Adam, thank you so much for your attention and help :) I got it fixed ultimately. And am now working on getting animations imported :) Did a few animations already for testing purposes and fun. As you can see i put [Solved] on my title here :)

heres a shot of me celebrating my workign import XD :P alt text

more ▼

answered Dec 19 '14 at 08:17 AM

avatar image

VRF
21 2 6 7

avatar image Valentin Slobozanin Jan 30 '15 at 06:28 PM

Hello VRF,

I'm having exactly the same problem. Where is the "ref 0 enabled" setting you are talking about?

avatar image VRF Feb 19 '15 at 05:15 PM

Hi ferocildo,

There is a button that says advanced settings when you upload.
It should open more option and then showcase you the ref 0 enabled button.

If you still have trouble finding it i can make a screenshot for you.

avatar image EroDera Feb 20 '15 at 12:57 PM

Hello VRF, did you mean this option? Hope not, beacause this does not seem to do anything in my case.

avatar image EroDera Feb 20 '15 at 01:02 PM

Hi VRF, Is the option I highlighted on the picture the one you had in mind? If not would you please post that screenshot?

avatar image EroDera Mar 01 '15 at 05:27 PM

Hi would you please submit screenshot of your ref 0 enabled button? Or any other info about how to unSmurfify my character? I really really need to solve this. Thx in advance

avatar image EroDera Mar 01 '15 at 09:46 PM

Just solved in now. So never mind :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question