x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Launcher Update Stuck on Downloading

Hello , i just compile and run the Editor.exe and when click on the "Marketplace" it shows me "Updating Unreal Engine Launcher

and everytime it shows me 70~85 MB left , and stuck on 80~81% and nothing happened !!! is that normal !? because my connection does not have any errors !

Product Version: Not Selected
Tags:
more ▼

asked Mar 21 '14 at 08:53 PM in Installation & Setup

avatar image

Viper
31 1 2 4

avatar image ali-q8 Mar 27 '14 at 04:22 PM

I have the same problem please help

avatar image Gmaster Mar 27 '14 at 09:11 PM

I'm having the same problem, and none of the above worked. I believe that many users are having the same problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Apr 03 '14 at 05:13 PM by Stephen Ellis for the following reason:

Duplicate Question


13 answers: sort voted first

Hello!

If you are still experiencing issues with your download, please go here: https://answers.unrealengine.com/questions/24311/read-this-if-your-download-has-stopped-around-81.html

This topic is now being closed.

more ▼

answered Apr 03 '14 at 05:12 PM

avatar image

Stephen Ellis ♦♦ STAFF
11.5k 322 32 480

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

[Edit - updating answer to have all of the information contained in the thread]

Hi Viper, sorry for the inconvenience...

The real issue is that we have a global timeout that is set too agressively for slower connections, if 1 file takes longer than 3 minutes to download it times out and will attempt to retry it. Most of our data is chunked, and is usually under 1MB so that's ok even if you have a really slow connection, however at this point in the download it's attempting to download a 50MB file. The fix will be in a future version of the launcher, but for now, you can edit DefaultEngine.ini to increase the timeout value. You can find it here: "c:\program files\unreal engine\launcher\engine\programs\noredist\unrealenginelauncher\config\" and add the following section to the end:

 [HTTP] 
 HttpTimeout=1200
 HttpConnectionTimeout=600 
 HttpReceiveTimeout=600 
 HttpSendTimeout=600

If you have any additional problems after changing this setting, you can enable extra logging so we can help debug the issue. Add the following section to the same ini file you changed before. You can zip up the (Logs are in c:\users\YOUR_USER\appdata\local\unrealenginelauncher\saved\logs) and post the zip here. Thanks!

 [Core.Log]
 LogHttp=log
 LogOnline=verbose

Carlos

more ▼

answered Mar 22 '14 at 01:57 AM

avatar image

Carlos Cuello STAFF
866 12 5 13

avatar image Viper Mar 22 '14 at 12:13 PM

unfortunately it did not work :( :(

here is the latest logs link text

logs.zip (68.3 kB)
avatar image Boompit Mar 22 '14 at 05:47 PM

Same problem here :(

avatar image Boompit Mar 22 '14 at 07:03 PM

How can you accept this as an answer when both of us said that it's not working? :|

avatar image Ben Halliday STAFF Mar 22 '14 at 07:35 PM

It's marked as an answer for now so that it gets pushed to the top, for easier reference by our developers. Sorry for any confusion.

avatar image Viper Mar 22 '14 at 07:37 PM

then thanks for it :)

avatar image Carlos Cuello STAFF Mar 22 '14 at 07:42 PM

Hmm, your still getting a bunch of timeouts even after increasing the time, can you go back into defaultengine ini and try increasing the numbers a bit more?

 HttpConnectionTimeout=240 
 HttpReceiveTimeout=400 
 HttpSendTimeout=400

avatar image Viper Mar 22 '14 at 07:51 PM

Nothing happened again ! :( its just stuck on 81% and told me 70MB remaining ep

ep.jpg (19.9 kB)
avatar image Carlos Cuello STAFF Mar 22 '14 at 08:11 PM

Thanks Viper, can you post the logs on here from this run? Can you try upping the timeout values again? Try: [HTTP] HttpConnectionTimeout=720 HttpReceiveTimeout=2000 HttpSendTimeout=2000

avatar image Viper Mar 22 '14 at 08:41 PM

i try this : [HTTP] HttpConnectionTimeout=850 HttpReceiveTimeout=2000 HttpSendTimeout=2000

and here is the 2 new logs with new settings :( Logs

logs.zip (59.6 kB)
avatar image Carlos Cuello STAFF Mar 22 '14 at 09:05 PM

Thanks for trying that Viper, we think we might have a new QFE for you to try soon, will update this thread as soon as it's available.

Carlos

avatar image Viper Mar 22 '14 at 09:29 PM

Ok then i will wait for this Quick Fix Eng. , and thanks so much Carlos , and thanks to UNREAL

avatar image Carlos Cuello STAFF Mar 22 '14 at 10:55 PM

Ok Viper, it's ready! You'll have to do the following:

  1. Download the QFE from here: http://cdn.unrealengine.com/qfe/UnrealEngineLauncher-QFE-FromCL2031728.zip

  2. Replace the EXE from the "Unreal Engine\Launcher\Engine\Binaries\Win64" Folder with the one in the zip.

  3. Add "-CPLabel=QFE2" to the command line of your shortcut.

avatar image noslopforever Mar 23 '14 at 01:34 AM

I have the same problem. I tried this QFE and everything is ok Now. Thanks for your help !

avatar image Totoroteto Mar 27 '14 at 12:01 AM

Thank you!! Worked for me too.

avatar image Viper Mar 23 '14 at 01:03 AM

YEEESSSSSSSSSSSS !!!!!!!!!!!!!!!!! Thanks Thanks ! its launched ! i see the market place !!! thanks so much !

avatar image Arshia001 Mar 23 '14 at 05:04 AM

This fix just worked for me as well, so thanks a lot for the support :)

avatar image thestubborndev Mar 23 '14 at 05:58 AM

Do you have the Quick Fix for Mac? I have the same problem but installing Unreal Engine not the Launcher.

avatar image Dre Apr 02 '14 at 09:38 PM

My problem has been solved thanks to the QFE. Thanks!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Epic,

I have not seen a reply from you about this issue lately. I am again experiencing the problem. I have removed all command-line arguments from my launcher shortcut, because I want it to update to the latest version. I start the launcher, it downloads something of 87MB, but stops at 81%. I get no error, probably because I have set my Http timeouts to insanely high values, there is just nothing downloading.

Are you still working on a solution for this bug? Will the launcher be able to download a fix itself, when it is available, or is more manual intervention required?

Thanks for all the support, the QFEs were great, I hope I am not a nuisance with all my posts here, I am just hoping I will soon be able to run the launcher and it will update successfully :|.

Thanks, Marius.

more ▼

answered Apr 01 '14 at 07:55 PM

avatar image

Marius
31 7 11 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My Launcher log:link text

more ▼

answered Mar 27 '14 at 04:11 PM

avatar image

kassane
43 1 3 5

avatar image ali-q8 Mar 27 '14 at 04:28 PM

it's working Thanks kassane

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My problem has been solved with launcher. After using http://cdn.unrealengine.com/qfe/UnrealEngineLauncher-QFE-FromCL2031728.zip and extract it in the folder "C:\Program Files\Unreal Engine\Launcher\Engine\Binaries\Win64", add the command -CPLabel=QFE2 -LauncherLabel=QFE3 -AppLabel=Production-HotfixPreview in the shortcut. Myloglink text

more ▼

answered Mar 30 '14 at 07:56 PM

avatar image

kassane
43 1 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So I did the increasing of the timeout stuff. That alone did not work. Then I did the


Ok Viper, it's ready! You'll have to do the following:

 Download the QFE from here: http://cdn.unrealengine.com/qfe/UnrealEngineLauncher-QFE-FromCL2031728.zip

 Replace the EXE from the "Unreal Engine\Launcher\Engine\Binaries\Win64" Folder with the one in the zip.

 Add "-CPLabel=QFE2" to the command line of your shortcut.

This then throws an error (ERROR! Unlisted Build Label:QFE2")

When I hit okay, it brings me to the Launch window anyways and allows me to work. But this error is unnerving me. :)

more ▼

answered Mar 27 '14 at 06:13 PM

avatar image

Ozzle
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey

I tried it and it's still not working! :(

Here's my log:

[1]: /storage/temp/2010-logs.zip

logs.zip (68.5 kB)
more ▼

answered Mar 22 '14 at 05:51 PM

avatar image

Boompit
11 4 7 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Really !?!?!? Answered !?!? No its not answered ! problem exist and nothing happened ! please saw the log files and tell me whats wrong :)

i know shit always happened , even in big , adulated high-end tech Companies and software's , but support team gonna make through these kinda problems ! its whether ours or Your's problem , so please lead us to make it , as one word we need some UNREAL Help :D !

thanks UNREAL

more ▼

answered Mar 25 '14 at 10:32 PM

avatar image

Viper
31 1 2 4

avatar image leighswift STAFF Mar 26 '14 at 01:38 PM

Hi Viper,

Sorry, we thought that you were all good now as you said you'd got into the market place. Maybe it was a lucky time :).

If you are still having issues with downloads appearing stuck, or subscribe buttons (both symptoms of similar issue) could you try an extra HTTP timeout value.

Locate DefaultEngine.ini

C:\Program Files\Unreal Engine\Launcher\Engine\Programs\NoRedist\UnrealEngineLauncher\Config\DefaultEngine.ini

Add to the very end the following four separate lines:

[HTTP]
HttpTimeout=600
HttpConnectionTimeout=180
HttpReceiveTimeout=180
HttpSendTimeout=180

Remember to try and give the download enough time to actually fail and present an error message. These timeout values can make that seem a long time.

Also if you let us know what your connection speed is we could help make sure these values are correct for you personally. The numbers from a speedtest site would be great:-

http://www.speedtest.net/

Thanks,
Leigh

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same problem,I have downloaded and copied the "qfe" but where and how do I add the command line?

more ▼

answered Mar 29 '14 at 04:00 PM

avatar image

Watson
1 1

avatar image Ben Halliday STAFF Mar 29 '14 at 04:03 PM

Hey Watson,

Right-click your shortcut to the .exe and select Properties. In the Target textbox, add a space at the end of what's already there and then the command line.

Ben Halliday

avatar image Watson Mar 29 '14 at 08:28 PM

Hi Ben Halliday thanks ,but seems to have fixed itself somehow

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi guys. I had the same problem, and it was fixed after I applied the QFE (http://cdn.unrealengine.com/qfe/UnrealEngineLauncher-QFE-FromCL2031728.zip) as described above. My download finished. But now again the same thing happens, but at 26%. I tried the QFE procedure again, but it does not work, my download keeps stopping at 26%. I also tried increasing the HTTP timeout settings - no luck. I even tried loading the QFE3 which I saw a beta was available - no luck. UE4 is absolutely awesome so I hate to say this but it seems like the launcher updating code has a serious problem somewhere. Please help! Thanks.

more ▼

answered Mar 29 '14 at 05:57 PM

avatar image

Marius
31 7 11 12

avatar image Marius Mar 29 '14 at 09:54 PM

Hi,

I have found that I can make the downloading resume after it has stopped by pausing the download, going to my network settings, disabling my network, enabling it again, and resuming the download.

Hope this helps someone, Cheers, Marius.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same issue. After applying the new exe and adding the argument to the command line, it seems the engine is re-downloading completely. Hopefully I can get in once its finished

more ▼

answered Apr 01 '14 at 06:36 PM

avatar image

midg3t
21 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have created a new thread for our problem, as I think this one is becoming quite confusing and hard to navigate. I am hoping that the new thread will provide a place for the Unreal support guys to more clearly answer us.

https://answers.unrealengine.com/questions/23424/launcher-update-stop-at-80-percent.html

Hope it helps, cheers, Marius.

more ▼

answered Apr 02 '14 at 11:33 AM

avatar image

Marius
31 7 11 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question