x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender Animations Not Imported Correctly

Hello all, I have made a door, along with 4 animations. I exported the model from Blender to a .fbx file, then imported the file to UE4. I imported it as a skeletal mesh and it appeared to have imported fine, but as I was looking at the imported animations in Unreal, I noticed that only one of the animations had imported correctly. In 2 of them, a bone was rotated 90 degrees, and in the other, a bone was moved straight down to the floor. I tried applying location, rotation, and scale in Blender many times without results and I'm not sure how to go about solving this problem. Also when I imported to UE4, the mesh didn't snap to the ground, it hovered about 10 units above the floor when placed, even though in Blender it is positioned perfectly to the floor (not sure if this has to do with the animations). If someone could give me some insight on what the problem might be or perhaps download the file and try to replicate it, the Blender users and I would very much appreciate it. The Blender and .fbx file (.zip)

Product Version: Not Selected
Tags:
more ▼

asked Dec 14 '14 at 04:08 AM in Using UE4

avatar image

vgripps123
0 1 1 2

avatar image Artur J. Feb 04 '15 at 08:17 PM

I have a similar issue. We discussed it here: https://forums.unrealengine.com/showthread.php?57983-Twisted-bones-when-playing-animation-Blender-to-UE4

I will need to use the 6.1 exporter for now with the "Convert Scene" import option unchecked. What is interesting is that I stoped with the first animated object I tried, because the problem appeared and I thought that it was going to be the same for all the models/animations. But you reveal that not all the animations of an object are having problems...I will test more things with my twisted animated bone when I have time to see what in the animation can produce that.

avatar image Adam Davis STAFF Feb 05 '15 at 08:55 PM

Hi vgripps123,

What settings are you using when you export from blender? Additionally, have you pressed alt+g in blender to 0 out the location transform? To avoid the offset try using alt+g, this should set the door back to the editor origin.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi vgripps123,

We have not heard from you in quite some time. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered Feb 11 '15 at 08:06 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question