x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

After packaging game level, .exe file crashes at start?

I have a simple game level that I want to package for Windows (x64) in development. When I finish packaging the 'game' successfully. I navigate to the folder location of the game.exe file and open it, it immediately crashes with this window. What do I do? I only have some some simple Blueprint such as triggerbox and a matinee video that plays at start.

Here's the screenshot of the crash error: Crash Reporter UE4.6

Product Version: Not Selected
Tags:
more ▼

asked Dec 14 '14 at 07:43 AM in Packaging & Deployment

avatar image

Oblivion2500
143 16 26 129

avatar image TheFoyer Dec 14 '14 at 04:33 PM

I have the exact same issue. That actually makes me feel a little better (that at least it may not be on my end) What does your log look like? Mine isn't helpful at all.

avatar image Oblivion2500 Dec 14 '14 at 08:26 PM

Here's my crash log and .dmp file. I have no idea what causing this problem.

Crash Logs

gamecrash_logs.zip (14.8 kB)
avatar image Naters4lad Dec 14 '14 at 08:36 PM

In your crash logs I noticed this:

*LogWindows:

=== Critical error: ===

Assertion failed:

GConfig->GetInt(TEXT("TextureStreaming"), TEXT("MinTextureResidentMipCount"), MinTextureResidentMipCount, GEngineIni) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\Engine\Private\SystemSettings.cpp] [Line: 346] *

I don't have the engine source code available to me but that error means it's having trouble applying a value to the MinTextureResidentMipCount config variable. Trying going into the editor Project Settings -> Rendering -> and un-check Texture Streaming (and rebuild after that) and see if it works. Or at least doesn't crash after you package and launch.

avatar image Oblivion2500 Dec 14 '14 at 08:49 PM

I tried your solution, and not only it made the lighting quality and texture quality of my level look awful. I tried packaging it and launching it, it still crashes. EDIT: New crash log files: link text

crash_logs2.zip (14.9 kB)
avatar image Naters4lad Dec 14 '14 at 09:01 PM

Indeed. Disabling texture streaming will make the graphics look terrible but this was just for a test to see if it would run, which it did.

By chance, are there any errors with your Blueprint scripts? Perhaps you just deferred fixing them and possibly forgot about them? Though I suppose it wouldn't have let you package the game.

Just to test, I just created a new project for Windows only, packaged it and it runs on my computer. I did disable the OpenGL rendering as well as ensure it wasn't being built for any other platform aside from Windows.

avatar image Oblivion2500 Dec 14 '14 at 09:10 PM

I double checked to see if it's making it for any other platforms other than Windows. No, I do not have any blueprint errors. Still crashes...

avatar image Naters4lad Dec 14 '14 at 09:16 PM

Was this project converted from a different engine version? Also if you create a brand new test project, try and build that one, does it also crash after packaging it? Trying to determine if it's a problem isolated to that particular project or if there isn't something else happening.

avatar image Oblivion2500 Dec 14 '14 at 10:05 PM

I tried creating a brand new project and building it. It does crash after packaging it and launching it. I tried building a project with 4.5.1 and checked to see if it was a 4.6 issue, it is. The 4.5.1 works great after launching it. So, 4.6 is having issues with packaging games and launching them.

avatar image Funt Dec 15 '14 at 06:24 PM

Same here, new projects in 4.6 crash. The ones in 4.5.1 don't.

avatar image [Epic] Gribbs ♦♦ STAFF Dec 16 '14 at 02:46 PM

Howdy everyone,

Sorry that I am late to the party. I have been attempting to reproduce this issue and have been unsuccessful so far. I created a simple matinee to trigger when i enter a TriggerBox. I then packaged the project for Windows (64-Bit) and have not seen a crash. I have also tried to do this in an older version UE4, converting to 4.6, and still no error. Is there a simple way that i may be able to see this error via a setup or repro steps.

Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image Oblivion2500 Dec 16 '14 at 08:07 PM

Try adding a light importance volume, I read that is one of the problem causing it. I tried removing mine but it caused some lighting issues and did not fix the problem for me.

avatar image TheFoyer Dec 16 '14 at 08:09 PM

Interesting. Noted, I will try later this evening

avatar image Darknoodles Dec 17 '14 at 02:06 PM

Oblivion's solution worked for me. I had crash if i had Substance plugin enabled or Rift turned on, but since i added a lightmass importance volum it works ! Thanks Oblivion, i wonder how i could have missed that... And i wonder why the engine doesn't warn when you forget to place one, as it seems to cause many trouble when there is not

avatar image Naters4lad Dec 17 '14 at 02:20 PM

UE3 used to warn you about its absence. Not sure if UE4 does but this is good to know.

avatar image [Epic] Gribbs ♦♦ STAFF Dec 23 '14 at 04:18 PM

Hey Oblivion2500,

Just wanted to check in with you and see if you are still having issues with the .exe file crashing for you. If it is, would you be able to provide the pathing that you are using when finding the .exe file?

Any additional information on this issue would be greatly appreciated.

Thanks!

avatar image Oblivion2500 Dec 24 '14 at 07:04 PM

Yes, I'm still getting issues. The pathing to find the .exe file is: Desktop\UndergroundTunnel\WindowsNoEditor\Engine\Binaries\Win64\ I double click on UE4Game.exe and it still crashes giving me the same error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hey Oblivion2500,

Sorry to forgot to update this thread. I have entered UEDOC-768 into our Bug Database so that the documentation can fixed fixed to show the correct pathing to use when finding the .exe file. I will be sure to keep you updated as this bug is updated.

Thanks!

more ▼

answered Dec 24 '14 at 07:25 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Just to be sure, check if you are launching the right .exe file, because documentation is wrong about its location: https://answers.unrealengine.com/questions/149118/crash-after-packaging-event-an-empty-project.html

I've had the same crash error. You want to run the .exe straight from WindowsNoEditor folder.

more ▼

answered Dec 24 '14 at 07:18 PM

avatar image

Slavq
2k 157 153 207

avatar image Oblivion2500 Dec 25 '14 at 10:03 PM

Yes this solved my problem! I was running it of the binaries folder as told by the documentation. I ran the .exe from the WindowsNoEditor folder and it launched my game. Thanks! Hope Epic Games updates their documentation on this!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is really odd because I just created a new 4.6 project, configured for Windows platform, packaged and it works. Did you try verifying your 4.6 engine from the launcher? What i'm hoping is its a corruption of some kind.

more ▼

answered Dec 15 '14 at 06:50 PM

avatar image

Naters4lad
41 3 4 11

avatar image TheFoyer Dec 15 '14 at 06:56 PM

Are you a staffer?

I'm having the exact same issues as others have report with 4.6 packages crashing on launch. I also created a project from scratch, built it, and it worked. I spent hours converting all my asset to a brand new 4.6 project and I still have the same issue. The project packaged fine in 4.6 preview and not with 4.6. Yes I have also verified my engine, multiple times. This is a blueprint project and not a code project.

avatar image Moter8 Dec 15 '14 at 06:59 PM

Nope he's not a staffer. You can identify them with the tag near their username.

avatar image Naters4lad Dec 15 '14 at 07:00 PM

Nope. Just a regular user like you :) I'd also add when I converted my C++ project to 4.6 I had to do some manual code massaging but it wasn't anything that would break it. This is a really bizarre issue. Really wish I had answers.

avatar image TheFoyer Dec 15 '14 at 07:02 PM

I figured as much because you've helped us with this issue more than staff has ;) but this issue is pretty frustrating. I wish you had answers too lol. But thanks for the help anyway!

avatar image Naters4lad Dec 17 '14 at 02:21 PM

Cheers mate. Looks as though you may have an answer up there as well. Happy game deving :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi!

I read this topic and still searching for answers. I've got the same problem as described in the first post, the same crash and error at .exe launch.

I've tried many solutions and tweaks that I found here and elsewhere, but no success.

I started from FPS template that I modified (deleted all useless assets, deleted arms and gun for the FPS view, changed the walk speed and builded my scene) It worked perfect when I clicked Play-> Standalone Game. But the windows no editor .exe always crashes.

May be I missed something or didn't understand the workflow?

Did someone solved this issue?

Many thanks!

JC

more ▼

answered Dec 30 '14 at 08:09 AM

avatar image

JayC3D
30 8 12 17

avatar image [Epic] Gribbs ♦♦ STAFF Dec 30 '14 at 02:06 PM

Hi JayC3D,

I have entered a Jira report for this issue so that the documentation can be fixed to show the correct pathing to be fixed. For the time being, you should be able to use the .exe file in your WindowsNoEditor folder to launch the project and the one located in the Engine\Binaries\Win64 folder.

I am unsure as to when a fix in the documentation will be implemented but i will be sure to keep you posted as I see any progress being made to the report.

Thanks and have a great day!

avatar image JayC3D Dec 30 '14 at 03:17 PM

Hello Sean,

Thanks for your reply, I tried with the .exe in WindowsNoEditor folder and the one in Binaries\Win64 , still crash.

I don't know why...

avatar image [Epic] Gribbs ♦♦ STAFF Dec 30 '14 at 03:49 PM

Would you be able to attach that build log file so that I may be able to see what the error being thrown is? Could you also attach your DXdiag to this thread as well?

Any additional information would be greatly appreciated.

Thanks!

avatar image JayC3D Dec 30 '14 at 05:15 PM

Ok but how can I attach those files? It will be visible by anybody?

avatar image [Epic] Gribbs ♦♦ STAFF Dec 30 '14 at 05:41 PM

Is there an attach option when you make a comment. If you do attach a file to a comment, all users will be able to see the file. If you would like to, You can upload those files into a dropbox and then send me a link to that file via a private message through the forums. Here is a link to my page: https://forums.unrealengine.com/member.php?4890-Sean-Gribbin

avatar image JayC3D Dec 30 '14 at 07:26 PM

Ok many thanks, I'll it send to you tomorow I'm out of the office right now

avatar image JayC3D Dec 31 '14 at 08:25 AM

Ok I made some research yesterday night...

I found the solution!

I made a DxDiag and see that the .exe was searching for Exemple_map which does not exist anymore.

I started from FPS Template, modified the map and saved it as XXXX.umap (And deleted ExempleMap) In the editor -> Project settings -> Maps and Modes : I had to set my new map as the Game Default Map & Editor StartUp Map (For the next time I launch UE).

This solved my problem! I can launch my .exe package with no problem!

I hope this will help someone...

Many thanks

JC

avatar image [Epic] Gribbs ♦♦ STAFF Dec 31 '14 at 07:46 PM

Howdy JayC3D,

Glad to hear that you were able to solve the issue that you were having with the .exe file. If you run across this error again, please feel free to reopen this project so that i may further investigate.

Thanks and have a great day!

avatar image JayC3D Dec 31 '14 at 08:00 PM

Thanks! Have a great new year's eve!

avatar image [Epic] Gribbs ♦♦ STAFF Dec 31 '14 at 08:05 PM

And have a great new year's eve to you as well!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question