x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.6.0] Packaged "sample project" instantly crashes

Hi,

I'll be brief - I tried making a Blueprint-only GTA-like demo. In fact, it's pretty similar to the "possessing a pawn" tutorial from the Documentation / learn tab. Nearly identical even. (https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/PossessPawns/Blueprints/index.html)

I made a 3rd person project, followed by Vehicle project and setting everything up there. In this project, my character can get in and get out of the Sedan quite nicely. Then I decided to complicate things a bit, and threw in another round of the same thing (merging/migrating), just with VehicleAdvanced this time.

That turned out to work solidly well, except for the fact that I can get in/out of the buggy just fine, but once I get in the Sedan I cant get out of it. I kinda tracked that bug down to something related to HMD and something nulling itself out... tho that is far from the topic of the question.

What I wanted to "package" was that Sedan (vehicle) sample map, or the All-Terain (advanced vehicle) sample map, with a Sedan and a Buggy on it. I wanted the Player to be able to get in and out of both vehicles, or just the buggy with the sedan remaining "enter only and restart the game when you want to exit it". (like it works in the editor)

Yet looking through the logs, I kinda found that the reason the project instantly crashes is because it just can't find '/Game/Maps/Example_Map'.

I kinda remember the drill - upload the Output Log, upload the logfiles from the Saved folder, but what else do I need to post so you can "start looking at it on your end" ? I'm bothering to post this because... well, following a featured tutorial from the Learn tab on the newest version of the engine is kinda expected to work much better than this.

It works great&fine in the Editor, just that when Packaged for Win64 (I didn't try Linux or Android yet) the thing can't even start properly. So I'm not feeling too confident that trying it out for Linux/Android would get me better results since I can't get it working as decently as it does while-playing-in-editor.

Turns out, the exact same thing happens when I package my 2nd step project (Vehicle) instead of the 3rd step (VehicleAdvanced)

Please suggest how to fix or give advice :) I am totally willing to share/upload this project (or all three steps of it) if you're interested in that. Thanks in advance,

-Aleksandar

uploads:

output log grabbed manually from the Editor

WindowsNoEditor\Vehicle\Saved\Logs\Vehicle.log

Product Version: Not Selected
Tags:
output log.txt (1.2 MB)
vehicle - copy.txt (15.2 kB)
more ▼

asked Dec 14 '14 at 04:20 PM in Packaging & Deployment

avatar image

devshark
24 3 9 14

avatar image Oblivion2500 Dec 14 '14 at 11:04 PM

I'm getting the same thing. All maps I packaged in 4.6 crashes immediately after launching. 4.5 worked great!

avatar image devshark Dec 16 '14 at 11:25 PM

Same thing happens on 4.6.1 :(

avatar image Darknoodles Dec 17 '14 at 01:42 AM

I get the same issue wit my project. Disabling Substance plugin (if you use it) and turning off the rift let me sometimes run the game, but if one of them are enable it is no luck...

avatar image devshark Dec 17 '14 at 08:58 AM

I'm not using Substance or Oculus Rift so we kinda need a different solution (or a workaround) for this.

avatar image devshark Apr 17 '15 at 08:40 AM

Hello,

I will investigate later today / over the weekend and give you a status update with both 4.6.x and 4.7.5.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi all,

Are you still seeing this issue? Have you updated to the newest version of the editor? We are at 4.7.5 now.

more ▼

answered Apr 16 '15 at 09:14 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question