x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to get rid of floating shadows at distance.

I am making a top down view kind of game, almost birds eye view setup, so everything is fairly large and far away from the camera. UE4 really optimizes the shadows at such distances, so I feel like I am working against it. But its pretty good as it is, just wish it was "perfect" to my eye.

Here are some pictures to show the issue: Distance shadow optimization Up close shadows are sharp

As you can see when zoomed in the edges are crispy and accurate, at distance they "float" and have rounded corners.

My questions is, has anyone tackled this problem? If so how did you solve it? I've been playing with the console r.Shadow.* settings for a while but can't find anything that would let me force the camera/engine to always show shadows at close-up quality.

My console settings to get the current result are as follows (some might not be doing anything): Console startup commands for crispier shadows.

Thank you!

Product Version: Not Selected
Tags:
01.jpg (87.8 kB)
02.jpg (162.4 kB)
03.jpg (71.3 kB)
more ▼

asked Dec 14 '14 at 09:53 PM in Rendering

avatar image

mxnko
219 16 28 36

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You could enable Inset Shadows for those meshes to get rid of that problem. I'm not sure if inset shadows or increasing shadow quality with console commands would be better for performance so you'll need to try and see for yourself. Also, put the commands in Engine > Config > ConsoleVariables.ini.

more ▼

answered Dec 14 '14 at 10:08 PM

avatar image

Jacky
16.8k 671 167 676

avatar image mxnko Dec 15 '14 at 03:10 AM

Inset shadows doesn't seem to do anything. I think there is a settings somewhere that determines camera distance in relation to most accurate shadow settings being rendered (since I am getting accurate shadows when I zoom in).

I will move those to .ini thank you!

avatar image mxnko Dec 15 '14 at 07:02 AM

Ok, I am not sure what I did, but I've created a new project tweaked lights for a while, and now inset shadows create sharp shadows just like desired. Thank you!

Attaching screenshots: Console vars Result

01.jpg (94.6 kB)
02.jpg (81.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question