x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I disable all post processes entirely?

I looked up every question in the forum, but I can't disable PostProcessing entirely. Here is my setup:

  • I disabled post process in the project settings

  • I turned off every effect in the camera's setup

  • I use a post process volume, where I turned off everything

Still, when I start my game in standalone mod (and I press "ctrl + shift + ,") I can see that post process is still on. I want PostProcessing to be 0.0. How can I do that?

Thank you in advance.

Product Version: Not Selected
Tags:
more ▼

asked Dec 15 '14 at 10:11 AM in Rendering

avatar image

Andras2014
55 7 13 16

avatar image RomanL Dec 15 '14 at 01:43 PM

What specific type of post-process are you still seeing in the game?

Did you followed through every list in the world settings to disable every feature accordingly? For example Auto Exposure post-process is disabled only when Min and Max exposures are equal. Also you don't need to use such complex approach - just setup everything via World Settings

avatar image Andras2014 Dec 15 '14 at 02:33 PM

Please find the picture of my setup enclosed.

alt text

Now I only have a camera attached to the character. I typed in 0 to all values, then I unchecked all the boxes. (Unfortunately it doesn't make any difference.) I do know that these values are pretty low already, but the game is intended to run on android. (https://answers.unrealengine.com/questions/147272/how-to-increase-performance-on-android.html - this was my main question.)

Furthermore, since I can't check these values on android, I assume that postprocessing uses up there also more than 80% of the resources.

postprocess01.png (946.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Here you go - this setup worked great for me and as you see there is no PostProcessing step in rendering graph. Just setup your PP Volume as seen on the screen and disable MobileHDR in your ProjectSettings. This way all post-process features will be disabled.

alt text

off_screen.jpg (353.2 kB)
more ▼

answered Dec 15 '14 at 04:39 PM

avatar image

RomanL
221 5 5 16

avatar image RomanL Dec 15 '14 at 04:44 PM

BTW you could check this values in MobilePreviewer (it will gave you more accurate result for what is actually rendering on mobile) also by typing "profileGPU" as a console command

avatar image Andras2014 Dec 15 '14 at 04:46 PM

Thank you, I am going to implement these settings ASAP.

profileGPU didn't work on the device, the game just quit every time I entered profileGPU.

avatar image RomanL Dec 15 '14 at 04:56 PM

That's weird. Works for me on Mobile Previewer (not on device) with UE 4.6

avatar image Andras2014 Dec 15 '14 at 05:02 PM

I copied everything what I saw on the picture, but the post process duration did not change in the standalone game mode. When enter the same keyboard shortcut to see GPU visualizer on the mobile preview, it does not show post process.

Is the picture that you posted from a mobile preview or from a console preview? And by the way how can you type commands in the editor? (I only know this shortcut, and the stats on mobile.)

avatar image RomanL Dec 15 '14 at 06:57 PM

This GPU visualizer results pictured on my screenshot is from Mobile Previewer (since you've mentioned that project is intended for Android). The global shortcut for openning console is the same for all platforms '~' (works in the viewport too). I didn't get how you open GPU visualizer with shortcut, but there is console command that is working on any platfrom - "profileGPU". That's how I get results for my test

avatar image Andras2014 Dec 15 '14 at 07:41 PM

The shortcut is "control + shift + ,", the last one is a comma.

However, I can't open the console command box (it turned out I have a different binding assigned, so wrong key press can't be the cause). I have also tried opening it in the tappy chicken template, but I just can't. Do I need maybe microsoft visual c++ to be installed on the computer?

https://answers.unrealengine.com/questions/94518/cant-open-console.html the answer for this question can't be the solution either.

avatar image RomanL Dec 16 '14 at 10:41 AM

If you installed all prerequisites (it includes ms visual c++ redist too) that should be enough. That's completely weird since console works great in any kind of Play session for me

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question