Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging for Android doesn't work

I wanted to package a project for Android but everytime I try to do so, it seems as if it has worked, but when I look into the folder I set up, there is always only a version for WIN64 in it.

Am I doing something wrong, or is this a known bug?


Product Version: Not Selected
more ▼

asked Mar 21 '14 at 09:47 PM in Packaging & Deployment

avatar image

1 1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I figured out how to solve it.

I had the android sdk installed manually. That gave me the ability to launch games on my device from the editor so I figured it worked. (did everything the wiki said)

Seems like it's not enough though. I got rid of all these things and then installed the Nvidia Tegra Dev platform, which installs the Android SDK, Java and a few more things. Now I can package the game just fine.

If you wanna try it yourself, you can find the nvidia setup in your unreal engine folder: Program Files\Unreal Engine\4.0\Engine\Extras\Android\tadp-2.0r8-windows.exe

more ▼

answered Mar 23 '14 at 02:33 PM

avatar image

86 3 3 9

avatar image BKremnev Mar 23 '14 at 03:26 PM

So you need to install tadp and rebuild engine after that?

avatar image PockyWitch Mar 23 '14 at 03:28 PM

I just installed tadp, launched UE4 and tried to package the project. Worked fine on the first try. Didn't have to reinstall UE4 or anything.

avatar image kenshin1987 Mar 25 '14 at 07:48 AM

hi,do you have the file ue4game-armv7.apk ue4game-armv7.so in Binaries/Android? I have installed tadp ,but still not work.

avatar image BKremnev Mar 25 '14 at 08:04 AM

Run GenerateProjectFiles.bat again and rebuild engine. Worked for me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question