x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I get rid of incompatible version warning?

Dear all,

I have been using 4.5 branch from GitHub while creating some content. Because it is easier to coordinate with the team, we switched to 4.6 from luncher. After fixing initial API changes, everything runs smoothly but I am receiving (annoying) warnings every time I lunch or package the project:

Asset '../../../../../../Arenaz/Arenaz/Content/Effects/Stuns/BP_Stun.uasset' has been saved with empty engine version. The asset will be loaded but may be incompatible. ....

This happens for all assets. Is there anyway to apply version to blueprint?

Best regards, Žiga

Product Version: Not Selected
Tags:
more ▼

asked Dec 15 '14 at 09:38 PM in Using UE4

avatar image

ziga.osolin
206 9 12 76

avatar image Doug E ♦♦ STAFF Dec 16 '14 at 08:00 PM

Hey ziga.osolin-

You should be able to right click the .uproject file inside the project folder and select the option to "Switch Engine Version" to the version you want to use (in this case 4.6). If it is a code project or has any code added to it, you'll then need to right click the .uproject again and select the "Generate Visual Studios project files". This should associate the project and its files to the version of the engine selected.

Cheers

Doug Wilson

avatar image ziga.osolin Feb 26 '15 at 07:44 PM

Sorry to reopen this issue this late but the solution you described does not work for me. The warning that the uasset files are saved without version remains. I have tried UE4Editor.exe -run=resavepackages -maxver=214 and it gets rid of some but not all warnings. All warnings still pop up when packaging.

avatar image Doug E ♦♦ STAFF Feb 27 '15 at 09:40 PM

Hey Ziga-

Are you still working in 4.6 or are you using 4.7.1 now? You could try verifying your engine version from the launcher by clicking the drop down arrow next to the version number and try launching the project again. Another option would be to remove the asset from the Content folder (simply move to the desktop or another folder) and open the project normally. Then you can import the asset back into the project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Doug,

I have been using the most recent stable version all the time, also updating to 4.7.1 did not change any of the import errors. From what I think I know is that some (100-200) of my 2000+ .uassets complain that they have been saved with empty engine version. The asset will be loaded but may be incompatible. I tried all you strategies: the engine is bound to version 4.7.1, I have recompiled and remade C++ part of the project several times, ... Removing the asset and reimporting works, as well as (in most cases) opening the asset and changing something about it, then saving. So the solution is just to resave the asset.

So if anyone has similiar issues, resave the assets in 4.7 and it should work (I think this did not work in 4.6). This issue arose by using 4.5 Git branch that saved the assets without version (I think). I am just wondering if there is a (command line) option to force resave all the assets to speed up my work, opening up 200 assets is tiresome.

Thanks for help

more ▼

answered Mar 01 '15 at 10:05 AM

avatar image

ziga.osolin
206 9 12 76

avatar image Doug E ♦♦ STAFF Mar 02 '15 at 06:33 PM

If you simply need to re-save the assets (and they are in the same project) you can use File->Save All to save everything in the current project (assets, blueprints, levels, etc.). If editing the asset prior to saving is needed the you will have to take the time to open and edit each, but can then do a Save All rather than saving individually.

Cheers

Doug Wilson

avatar image ziga.osolin Apr 10 '15 at 04:41 PM

Additionally, you can disable the warnings being shown (sometimes, indeed the warning may repop, at least in my case). You just need to add [Core.System] ZeroEngineVersionWarning=False to DefaultEngine.ini. Check https://forums.unrealengine.com/showthread.php?60828-Assets-quot-saved-with-empty-engine-version-quot-warning for discussion.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question