x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Slate UI cost (GPU Visualizer)

Hi, why SlateUI costs so much ms? Look at screenshot: alt text

It is possible to minimize this?

Product Version: Not Selected
Tags:
gpu.png (48.6 kB)
more ▼

asked Dec 16 '14 at 11:54 AM in Rendering

avatar image

kodmistrz
334 55 83 103

avatar image Illusionray Oct 06 '15 at 05:40 PM

Yeah, we are having the same problem with the SlateUI on Oculus Rift. It goes crazy with ms (almost the same as rest). Of course we are playing outside the editor.

avatar image devel.bmad May 19 '17 at 12:12 PM

Did you manage to fix the issue? I'm experiencing the same problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey kodmistrz -

The SlateUI is the UI for all of the editor and if you are pulling information from the GPU Visualizaer while PIE or Playing in a New Editor Window then you are also getting the GPU process for the actual Editor UI as well.

Thank You

Eric Ketchum

more ▼

answered Dec 16 '14 at 03:54 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image clt2488 Apr 06 '15 at 04:03 AM

Maybe that's true in some cases, but could that not always be the case? According to the GPU profiler, I'm getting 5-7 ms taken up by SlateUI even when I run my game without the editor open at all (by right-clicking on the project file and selecting "Launch game").

But I only get that much SlateUI time if I'm running in stereo mode (Rift). If I turn stereo mode off ("stereo off") my SlateUI time goes down to like 0.05 ms. Is something in stereo mode using Slate too?

avatar image Rudy Q ♦♦ STAFF Oct 06 '15 at 08:03 PM

Hello clt2488,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

  4. How many widgets do you have that are utilizing transparency?

avatar image clt2488 Oct 09 '15 at 04:40 PM

Sorry, I moved on from this project a while ago and don't have time to collect more info. I think I had a handful of widgets with transparency, but I don't remember for sure.

avatar image Rudy Q ♦♦ STAFF Oct 09 '15 at 05:10 PM

Hello clt2488,

That was my mistake, I meant to direct those questions at Illusionray. However, thank you for your response.

avatar image Rudy Q ♦♦ STAFF Oct 09 '15 at 05:10 PM

Hello Illusionray,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

  4. How many widgets do you have that are utilizing transparency?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

FRAME Leaf Events / SlateUI cost too much performace, it bother me for months, here is the solution:

there may have two possible evil cause this problem, one is the Geforce Experience's auto replay record, turn it off or just uninstall the Geforce Experience. The second may be the G-Sync, in the Nvidia Control Panel, make the G-Sync only run on fullscreen mode, or just turn off G-Sync. (should restart your unreal editor to see the result)

if your GPU is AMD Radeon, check the Radeon Overlay, or the FreeSync, maybe is the same problem.

more ▼

answered Apr 01 '18 at 01:30 PM

avatar image

surferHalo
46 1 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question