x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

C++ code won't compile windows.h

Hi there! This is a problem I can't solve. Everytime I try to compile Unreal Engine code I get this error: fatal error RC1015: cannot open include file 'windows.h'. And I can't figure out what is wrong. I have tried to install Windows SDK, re-install Unreal Engine and Visual Studio and so on. It just won't work. I have checked my environment varibles and those seem to be right. I have no special characters in my windows account name either. I don't know what to do. Any help is appreciated! I'm running a windows 7 64-bit machine.

Product Version: Not Selected
Tags:
more ▼

asked Dec 16 '14 at 07:33 PM in Installation & Setup

avatar image

AntiSC2
21 1 2 2

avatar image Doug E ♦♦ STAFF Dec 17 '14 at 09:52 PM

Hey AntiSC2-

Which version of the engine are you working with? Are you getting this error when building the code for a project or building the engine itself? I would check to ensure that there aren't any special characters in the file path that you're trying to build to. You may also want to check your antivirus to make sure it isn't interfering.

Cheers

Doug Wilson

avatar image AntiSC2 Dec 17 '14 at 10:58 PM

Thanks for the reply. Im trying to build the engine version 4.6, but the same thing happens when trying to build other projects. It's not the anti-virus as I have tested it. There are no special characters in the path I'm trying to build too. But there is an '&' in the visual studio path. Is that ok? If not I will have to re-install visual studio and unreal engine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I fixed it! My visual studio path included an '&' and after re-installing visual studio everything worked!

more ▼

answered Dec 18 '14 at 01:56 PM

avatar image

AntiSC2
21 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question