x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why do blueprint's not cull with a cull distance volume?

apparently blueprints don't cull!?!? so i have made a prefabs of walls to drag and drop into levels to make level building easier but i have so many of them in the game that it runs so slow because all the blueprints are being rendered am i doing something wrong or do blueprints really don't cull!? if so they need to fix that maybe add an option to allow culling in the blueprint editor for that selected blueprint

Product Version: Not Selected
Tags:
more ▼

asked Dec 17 '14 at 01:01 AM in Bug Reports

avatar image

connormurry
121 21 31 39

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I noticed i had an issue with a blueprint mesh, which was set to movable. Setting it to static fixed the issue for me.

more ▼

answered Feb 19 '16 at 12:11 PM

avatar image

unit23
508 33 48 85

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Connor,

This is a known issue that is currently being discussed. For reference the ticket number for this issue is UE-5467. I'll add this post to the ticket and once it's resolved I'll post back here with the update once this is verified fixed. :)

There is a workaround though that may work in the time being. In your BP you can select all your meshes and set a max draw distance. This will work the same as the CDV with exception that you'll have to manually set this for all your static meshes in your BP. You can select all the static meshes at once in your components tab and set them all at the same time. At least that way you do not have to set them individually unless you have a need to do so.

I hope this helps until this fixed! :)

Tim

more ▼

answered Dec 17 '14 at 02:26 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image connormurry Dec 17 '14 at 05:08 PM

Great! Im glad to here I'm not the only one with this issue but the issue with setting the max draw distance could you provide an example I am having trouble finding it?

avatar image Tim Hobson ♦♦ STAFF Dec 17 '14 at 06:45 PM

You can find this in the selected component in the components tab.

Use the search bard and just search max and it'll pop up or you can find it under the tab Rendering > LOD > Max Draw Distance

Here you can set the min and the max. You may only need the Max for most use cases though. :)

alt text

avatar image connormurry Dec 18 '14 at 12:25 AM

okay i tried it but now my thing is invisible

avatar image Tim Hobson ♦♦ STAFF Dec 18 '14 at 03:06 PM

Make sure you're setting a high enough max distance. I wouldn't use the min distance unless you absolutely need to. I'd keep that at 0 otherwise if you set a value of say 100 when you got to within 100 units (cms) of the mesh it would cull.

Usually when I test, and the same is true in this example, I placed a static mesh in my scene as a base with no cull. I then place the Blueprint with a max cull distance of 1500 next to it. I would spawn in close to the two meshes and then as I move away I can see it cull at 1500 units.

Give that a try and let me know how it works out.

Tim

avatar image Hyperloop Jun 29 '15 at 07:39 PM

Hi Tim, what is the status of this ticket now? Thank you so much!

Edit: just tested this in 4.7.6 and it is still an issue. It looks like this ticket is 7 months old, are there any plans to fix it? Since using blueprints is such a cornerstone of UE4, it seems like it's pretty important that they work properly with the rest of the basic engine functionality such as culling. The suggested workaround doesn't seem to work with dynamically spawned meshes within blueprints and even if it did it's not nearly as clean as using the existing culling volume functionality :D

avatar image Tim Hobson ♦♦ STAFF Jun 29 '15 at 10:07 PM

@Hyperloop

This is by design. Cull distance Volumes only support static objects. If the BP does not have any static objects then it will not cull. CDV's are static by nature. They require static objects to work correctly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

PEOPLE!! I think I may know a workaround!!! (It worked for me on 4.16.3): you have to add an arrow component to the static mesh of the blueprint. That way, your blueprint mesh will work with the cull distance volume even if its set to movable, but note that every time you modify your cull distance volume`s values, you`ll have to:

*set your blueprint mesh to static

*save (by the way, look at the "Current Max Draw Distance" value on your blueprint mesh as a guide)

*set your blueprint mesh to movable(i guess)

*save again

NOTE: I didn`t test it on a packaged game.

more ▼

answered Jan 02 '18 at 11:57 PM

avatar image

FBGPRO
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question