x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to import a changed skeletal mesh back into UE4?

Export a skeletal mesh from UE4 into maya -> Change it -> Re import changed mesh back into UE4 -> result

Error, Could not import Maximo_Maria1. Duplicate bone name found ('Maximo_Maria1'). Each bone must have a unique name. Error Multiple roots found

This has me stumped for some unknown reason, its probably something simple that I'm over thinking. I've tried renaming every bone (Or joint as its called in maya) yet same problem persists. Any ideas would be fantastic. Thanks in advance!

Product Version: Not Selected
Tags:
more ▼

asked Dec 17 '14 at 08:26 AM in Everything Else

avatar image

starksunreal
1 5 6 8

avatar image Steve Hardister ♦♦ STAFF Mar 02 '15 at 03:54 PM

In Maya, rename skeletion. You can retarget to the original skeleton later.

alt text

newskeleton.jpg (97.3 kB)
avatar image OptimisticMonkey Nov 15 '17 at 01:51 PM

Please help - still struggling- After exporting a skeletal mesh to Maya from UE, how do I unparent and remove dummy node without losing the skinning information?

Maya wont let me freeze or reset dummy transformation because of the skinning info?

Thanks in advance for any help

avatar image OptimisticMonkey Nov 15 '17 at 01:53 PM

Ok - I think I got it:

In order to get rid of dummy node without losing skinning info: my suggestion would be to dupicate and copy the skin weights over.

  1. duplicate your rig.

  2. freeze the transforms you need to freeze.

  3. duplicate the mesh.

  4. bind your duplicate mesh to the duplicate rig.

  5. select the original mesh and shift+select the duplicate mesh

  6. skin > edit smooth skin > copy skin wieghts [option box]

  7. in the copy skin weights window choose edit > reset

  8. click copy

avatar image razmaz51 Apr 23 '19 at 10:09 PM

how did you unparent and remove the dummy node? this is driving me nuts.

avatar image mrwrong138 Apr 28 '19 at 10:11 AM

did you figure it out lol?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try GeoDav's answer here: https://forums.unrealengine.com/showthread.php?18094-Import-Skeletal-Mesh

my guess is that you have exported the character and imported a modified version, the problem is that when you export a skel mesh from UE4 it adds an extra root bone (standard for fbx api) there's a good chance that this "root" bone is named the same as the mesh, so you need to delete it before you export from your 3d program, the lowest bone name should be b_root , that is if you are using the Epic content

I also found this:

When exporting HeroTPP.fbx from Unreal, for some reason, a dummy node called HeroTPP is also added to the bones system when you open it in 3D Max. If you delete that HeroTPP dummy helper, everything works like a charm!

more ▼

answered Feb 25 '15 at 10:32 AM

avatar image

Napoleonite
590 89 103 153

avatar image WixZ May 14 '17 at 03:51 PM

Thank you man, had the same problem. Your answer was the solution. God bless you.

avatar image spdemille Jul 08 '17 at 09:40 PM

This is exactly the issue. I unparented and removed the added dummy node. after that it imports back into UE4 just fine using the old skeleton on import. thx! :)

avatar image razmaz51 Apr 23 '19 at 10:12 PM

how do you unparent and remove? if I select the mesh and unparent , it disappears.

avatar image razmaz51 Apr 23 '19 at 10:39 PM

if I open the hypergraph it shows the skeleton, root is at top , but above it is "jacket" (which this is a skeletal mesh named jacket), also at the very bottom is another "jacket" below the whole skeleton. if I try to select the bottom "jacket" and delete , the mesh disappears. if I select the top "jacket" and delete , everything disappears.

avatar image EsmailJ May 20 '19 at 07:02 PM

i had this problem too and now i solved with your help.thank you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question