x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Invisible collision of a monster after killing it

I have a problem like this: alt text

As we can see on this pretty picture - after killing a monster, i set Set Simulate Physics, so it becomes a ragdoll (+ then add impulse to throw it away, etc.) It's cool, but after killing, monsters' collision remains in the place it was killed! I've tried Set Actor Enable Collision to false after death and it works, but it causes ragdoll to fall through ground... I've thought that maybe it's Capsule collision from Character Movement component. So i've tried to Deactivate / Destroy this component but nothing, collision is still there. How to eliminate this invisible collision?

Product Version: Not Selected
Tags:
more ▼

asked Dec 17 '14 at 07:39 PM in Blueprint Scripting

avatar image

Slavq
2k 157 153 208

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You need to disable the capsule collision would be my guess man!

     CapsuleComponent->SetCollisionEnabled(ECollisionEnabled::NoCollision);
     CapsuleComponent->SetCollisionResponseToAllChannels(ECR_Ignore);


I absolutely loved the picture by the way :P

-Just noticed you tried this as well. I would also look into making sure that your skeletal mesh has collision on it as well. Also check that you don't have other components throwing collision. Is this replicated or on the client?

more ▼

answered Dec 17 '14 at 07:41 PM

avatar image

Nice_Rain
249 13 14 30

avatar image Slavq Dec 17 '14 at 08:10 PM

Arrrgh my dumb mistake. I've just destroyed Capsule Component and it worked! Previously, instead of destroying / disabling collision on Capsule Component itself, i was trying to do this on Character Movement component. Thanks :D

avatar image thankstipscom Apr 13 '15 at 03:22 AM

Thanks! Worked perfect in blueprints. (Destroy Component)

  • for the picture lol

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question