x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GenerateProjectFiles.bat "We couldn't find a valid installation of Visual Studio"

I have the following error described in other threads, but their solution doesn't work for me so bare with me ; ) "GenerateProjectFiles ERROR: We couldn't find a valid installation of Visual Studio. This program requires either Visual Studio 2013 or Visual Studio 2012. Ple ase check that you have Visual Studio installed, then verify that the HKEY_LOCAL _MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\12.0\InstallDir (or HKEY_LO CAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\12.0\InstallDir on 32-bit machines) registry value is set. Visual Studio configures this value when it is installed , and this program expects it to be set to the '\Common7\IDE\' sub-folder under a valid Visual Studio installation directory."

Here is my setup: I am runing W7 64bits with Visual Studio Community 2013 My Unreal engine repo is on the E drive, on: "E:\Projects\UnrealEngine" My VS is installed here: "C:\Program Files (x86)\Microsoft Visual Studio 12.0"

I have a system variable: "VS120COMNTOOLS" = "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Tools\" I have "C:\Windows\System32\" in my "Path" System variable. I have a registry key in "HK_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\VisualStudio\12" called "InstallDir" = "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\"

So I looked into solutions like: https://answers.unrealengine.com/questions/63040/generateprojectfilesbat-doesnt-recognize-visual-st.html that didn't help

And https://answers.unrealengine.com/questions/73003/generateprojectfilesbat-not-finding-vs.html that didn't help either.

I uninstalled and re-installed VS to no avail Re-downloaded the repo run ran Setup.bat again, no chance.. I've also tried to put the repo on the C drive.

Could it come from the fact that I am using VS 2013 Community ?

Thanks guys!

OeilDeLance

Product Version: Not Selected
Tags:
more ▼

asked Dec 18 '14 at 10:14 PM in Installation & Setup

avatar image

OeilDeLance
43 9 12 75

avatar image OeilDeLance Dec 19 '14 at 12:03 PM

Update: I just installed Visual studio express, that didn't change anything.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Okay solved it, The problem was that the PATH variable had two paths defines:

  • C:\Windows\System32\;

  • C:\Windows\System32;

Removing the second one fixed it. Also I am not sure if it works with VS Community

more ▼

answered Dec 19 '14 at 01:10 PM

avatar image

OeilDeLance
43 9 12 75

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question