x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Decal opacity mask not working - why?

alt text

I've also tried connecting alpha channel, red channel, etc. + changing opacity mask value, changing sampler type... - still not working. What's wrong with this material?

UPDATE: When spawned in world, opacity mask is working, but not properly - instead of "X" i have two parallel lines... Very similar problem to this: https://answers.unrealengine.com/questions/66356/decal-become-square-when-spawning.html

Product Version: Not Selected
Tags:
decalopacity.jpg (146.5 kB)
more ▼

asked Dec 19 '14 at 12:14 AM in Rendering

avatar image

Slavq
2k 157 153 208

avatar image AndrewHurley Dec 19 '14 at 06:57 PM

Hello Slavq,

What you need to do is change your 'Decal Blend Mode' to 'Masked' instead of 'Translucent', and plug your masked texture sample into the 'Opacity Mask' pin slot.

Hopefully this resolves your issue, but if you are still not able to get your material to function properly, let me know and we can further investigate.

Thank you,

Andrew Hurley

avatar image Slavq Dec 19 '14 at 07:07 PM

I don't have "Masked" mode there: alt text

material.png (20.0 kB)
avatar image AndrewHurley Dec 19 '14 at 08:13 PM

No worries that was my mistake. I set up my own decal material using the 'Emissive' Decal Blend Mode and was able to get the opacity mask through a Linear Interpolation. Use the images below as a reference on how to set up your own material.

Material Set Up alt text

Material Applied as Deferred Decal alt text

Hopefully this is the outcome you are looking for, but if you still need some assistance let me know.

Cheers,

Andrew Hurley

avatar image Slavq Dec 19 '14 at 08:44 PM

Thanks, but i get weird deformation - instead of "X" i have two parallel lines: alt text

Material setup is the same, however, i've noticed that my "Opacity Mask Clip Value" is active (not greyed out like in Your screenshot): alt text

I've tried putting other textures to be sure that's not a problem with this particular "X" texture.

EDIT: I've changed back to Surface, then changed Blend Mode from Masked to Opaque. Then changed back to Deferred Decal - now it's exacly the same as in your screenshot, but it's still deformed.

1.png (1.5 MB)
2.png (205.7 kB)
avatar image AndrewHurley Dec 22 '14 at 03:20 PM

Hey again Slavq,

The next thing I suggest is sending me the texture sample, "X", you are having trouble with and letting me test it on my end as well.

When sending a file, you need to zip it up into a folder in order for AnswerHub to allow you to attach it here.

Thanks,

Andrew Hurley

avatar image Slavq Dec 22 '14 at 03:26 PM

Here it is: link text

I've also tried with other textures, but maybe i'm saving them in wrong format or something... Thanks

xmarktexture.zip (7.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Slavq,

The problem is with your arrow facing for the decal. The decal is applied to a surface in the direction in which that blue arrow is facing. Here is exactly what I am talking about.

Properly Applied Decal alt text

Improper Arrow Direction Decal alt text

This should resolve your issue! :)

Cheers,

Andrew Hurley

xdecal.png (664.5 kB)
more ▼

answered Dec 22 '14 at 04:11 PM

avatar image Slavq Dec 22 '14 at 04:18 PM

Aaah, so that was it... It worked, thanks! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question