x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Flipping normals / Invisible walls

For the life of me I can't figure this out. I made a house in 3ds max and imported it as a FBX file into UE4. When I go inside the house, you can see through the walls. So I imported the fbx file back into 3ds max, selected the faces and flipped the normals. When importing these back into UE4 it's reversed, the outside walls are invisible but the insides are opaque with material. How do I make it so that both walls (inside and out) are opaque? You can download the file and check it out for yourself.

Product Version: Not Selected
Tags:
house_fbx.zip (191.5 kB)
more ▼

asked Dec 21 '14 at 03:03 AM in Using UE4

avatar image

SmokeyB
21 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

TheNoob's answer did not work and I don't have the time for the second option as I'm reaching a deadline but thank you for the answers, what I did was duplicate the house and flipped the normals on it, re-imported it and aligned it with the first house so it just looks like one house with all sides opaque.

more ▼

answered Dec 21 '14 at 02:38 PM

avatar image

SmokeyB
21 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

There is a setting in UE4 which allows to draw materials on both sides of mesh. To fix this check Double Sided Geometry Option under Static mesh settings inside Mesh Editor. Also check Two Sided Lighting in Details Panel.

more ▼

answered Dec 21 '14 at 08:48 AM

avatar image

TheNoob
11 2 3 5

avatar image Jjman739 Jun 16 '17 at 12:14 AM

And also make sure that the material is set to two-sided.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey (:

I can't check your fbx at the moment. Could you post a picture of your model? Without i can only guess:

The problem is, that a plane in 3D normaly only has one side. So if you create a wall for your house as a plane, it will only have 1 side textured. The other side is translucent.

I don't know about the setting "TheNoob" mentioned, but you could check if this easily solves it for you.

But i don't really think that it will. Your house should have 2 different texture on each side, for the wall outside and the fassade inside. But one Plane will only use one square for the UV Map. So it will have the same texture on both sides.

What you need to do is model your House with boxes as walls. This will give your 6 sides. Or 6 Planes. You can deletes planes or sides you don't need.

I hope this helps you. If not, please post a screen of your model so i can have a view on it.

more ▼

answered Dec 21 '14 at 10:13 AM

avatar image

eXi
6.8k 332 184 465

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question