x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Linking Library using the Build System is not working

I have attempted to load my library using the Build System (PublicAdditionalLibraries and PublicLibraryPaths) but the library is not loading that way. I removed the PublicAdditionLibraries entry and attempted to load my library with a pragma call which also failed. Once that was done I made sure that the path was correct by using the fully qualified (and escaped) path in the pragma call and it worked fine.

I ended up putting together the following hack to get the build working properly: https://wiki.unrealengine.com/Linking_Static_Libraries_Using_The_Build_System#Loading_Our_Libraries

basically I am just defining a constant and passing it in at built time.

Product Version: Not Selected
Tags:
more ▼

asked Mar 22 '14 at 06:46 AM in Bug Reports

avatar image

Bob_Gneu
374 6 11 79

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I am now able to link via the build system, the catch being that the PublicLibrariesPath list is not allowing me to put in the path on my other drives and the libs are being searched for in the install directory for UE4. I have confirmed this by passing the full path through to the PublicAdditionalLibraries list and confirmed that my libraries are being found. I will push a fix for this when i get to the root cause in the build system.

Until then, the following will allow anyone who is waiting for a fix:

 PublicAdditionalLibraries.Add(Path.Combine(V8LibrariesPath, "icui18n.lib"));
more ▼

answered Mar 25 '14 at 03:30 AM

avatar image

Bob_Gneu
374 6 11 79

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question