x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

BSP Brushes have invisible parts/sides issue?

Not quite sure if this is a bug, I have a issue where my BSP brushes geometry are having invisible faces and intersections that are completely see through. I have tried making a new BSP brush and placing it to the area where the other BSP brushes are getting invisible faces, the new BSP brush gets the same effect.

I have tried the following solutions:

  • Deleting the broken BSP and making a new one from scratch in the same place

  • Building the map/lighting

  • Deleting any large BSP geometry need the object

None of the above solution fixed the problem for me. Here's some screenshots of my problem: Invisible Face of BSP geometry

New BSP brush that have see-through if moved to certain area

Product Version: Not Selected
Tags:
more ▼

asked Dec 23 '14 at 06:51 AM in Bug Reports

avatar image

Oblivion2500
143 16 26 129

avatar image AndrewHurley Dec 29 '14 at 06:30 PM

Hello Oblivion2500,

A few quick questions.

Which version of the engine are you running?

Have you gone into your wireframe mode to make sure there are no subtractive brushes overlapping your additive ones where not desired?

If you have any sort of reproducible steps so I can maybe get the same results you are seeing on your side, that would be helpful as well.

Thanks,

Andrew H

avatar image Oblivion2500 Dec 29 '14 at 06:37 PM

I'm using 4.6.1

I don't have any subtractive brushes in my map. I can't figure out any sort of reproducible steps that produces the same results. It seems to only happen once you have a lot of brushes in the map. A weird thing is that sometimes it won't show until you open the project again and then the bug occurs.

avatar image AndrewHurley Dec 29 '14 at 09:14 PM

Do me a favor and if you are able to see any of these BSP errors currently. Convert the ones having the issue to 'Static Meshes' and see if that gets rid of the empty spaces.

BSPs are used for white boxing or creating the template for your level or game. We usually suggest that you convert these pieces of geometry to 'Static Meshes' once you have the correct size and shape you would like.

Let me know if this is useful as a workaround, or if you need further help.

Thanks again,

Andrew Hurley

avatar image Oblivion2500 Dec 30 '14 at 06:58 PM

Yes, it does get rid of the empty spaces when I convert to static meshes. I just get one problem though, the static mesh is gray with "invalid lightmap" all over it.

avatar image Lejoni Jul 11 '15 at 08:24 PM

I also encountered this problem, when I got up to using about 30 brushes. UE4 4.8.1 (built from latest git source release) on Linux Mint 17.2, GTX 770 Nvidia Driver 352.21

Converting my floor brush to a static mesh solved the problem for the moment.

avatar image AndrewHurley Jul 12 '15 at 02:46 PM

At the end of your project production, you will want to convert most, if not all of your BSP's to Static Meshes. BSP's are typically used for what is called, 'White Boxing' which means you are throwing together a quick layout of what you would like your level/scene to look like using BSP's as placeholders until you can replace it with the appropriate static mesh.

avatar image Khimari Sep 21 '15 at 03:33 PM

Holes in BSPs are caused by inapropriate vertex location when BSPs are crossing. It's violation of perfect plane. To better explain and replicate the issue, make two BPS cubes, switch to geometry editing (Shift+F5), select one BPS's vertex, grab it and drag it anywhere to break the plane among 4 vertex points. After done, intersect those two BSPs.

Result = hole...

Converting BSP to SM will fix this issue but sometimes you need to maintain BSP in it's presence because of substraction holes (doors, windows) and that is when the real HELL breakes loose...

Fast fix to maintain plane among many vertex points is to right click rougue vertex while snapping to grid is enabled. Put each point into perfect place and hit optimize. That will create correct plane. Sometimes you need to optimize the BSP geometry even when the plane is ok but some points are shifted - trapezoid. The issue usually happens when you disable grid snapping OR rotate your object, etc. That is when vertex gets out of grid. To easily fix vertex to go back to grid just enable snapping and right click the vertex in desired view. Yet sometimes this doesn't work OK....

:)

avatar image BigBossLucas Oct 25 '16 at 10:12 PM

I did all that and the issue is still showing, I Got a Box, a BSP brush, added a Texture with Opacity to one of its faces, it shows just ok in my Unreal Engine Viewport, convert the BSP Brush to Static Meshes, there are not other actors in the scene but a simple floor with no texture and my Box, and the default 1st person actor with that gun.

Then I did the 'recipe' stated by Andrew Hurley (see above), my box is still looking great in my viewport, then I build lights up, save my scene, and create an HTML Pack, No errors in the Log, I run the HTML content, everything just fine, but my texture is gone in my HTML5 build.

I'm running UE 4.13.1

Any further advice?

avatar image AndrewHurley Oct 26 '16 at 02:06 PM

Hey BigBossLucas,

So the issue you are reporting seems specific to HTML 5 and is different than the original issue that was posted by the original user. I resolved his issue, so for tracking purposes can you please create a new post and provide a link in your response.

Thank you,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

That is an easy fix :)

Double-click on the 'Static Mesh' within the 'Content Browser' and it will open up the 'Static Mesh Editor Window.' It is here you will want to assign the appropriate 'Lightmap Coordinate Index' to your mesh as well as its 'Lightmap Resolution.'

Use the image I have provided as a reference.

Static Mesh Editor alt text

Hopefully this resolves your issue.

Cheers,

Andrew Hurley

more ▼

answered Dec 30 '14 at 08:24 PM

avatar image Oblivion2500 Dec 31 '14 at 12:26 AM

That fixed the problem with the static mesh. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question