x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can only see imported mesh from certain angles

Hello, so I have this simple mesh I've made in blender: alt text

After importing it into UE4 I noticed that it's individual faces/planes are only partially visible: depending on the angle you're view them from.

Here is an example:

alt text

Here, only part of the faces are visible, but if you shift over a bit:

alt text

You can see some of the earlier missing faces. And if you continue even more:

alt text

You can see a different number of faces, I only the faces closest to you are invisible, how can I fix this?

So, how do I fix the issue of difference faces showing different angles depending on your viewpoint? Is this a bug?

I've tagged this as a bug, but if it turns out that it's my fault and I forgot to check a checkbox or something, I will untag it.

Product Version: Not Selected
Tags:
capture.png (19.5 kB)
capture2.png (437.9 kB)
more ▼

asked Dec 26 '14 at 02:16 AM in Using UE4

avatar image

ShrewGlue
409 97 83 106

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Zectric,

This is not a bug, as you've mentioned. This is a simple modeling issue that will need to be resolved in your modeling software (Blender in this case). The normals for the polygon's faces are flipped the wrong direction. This is why your mesh looks like it's flipped inside out. There is no face information on the backside which explains why you can see into the model and see the faces that way.

I don't use Blender so I can't explain the process to flip the normal in the program. But a simple Google search should provide sufficient results to get the normals facing the proper direction.

Thanks!

Tim

more ▼

answered Dec 26 '14 at 02:28 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 98 874

avatar image Rezental Dec 26 '14 at 02:56 PM
  1. Select all faces of your model

  2. Select "Shading / UVs" tab

  3. Press "Recalculate"

avatar image uw19 Oct 09 '15 at 05:13 AM

Perfect, thanks!! I've been having this problem and this fixed the issue. You the real MVP.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question