x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

cant build lighting

Hi! I'm Creating 3D side scrolling game for mobile and I created a simple map generator so the game is infinite. (I also have a destroy function that destroy the ground some seconds after the player had passed them.

So the problem is that I can't build my lighting. When I clicked on the build icon the engine freezes. (I have GTX 760 2GB, and all my other projects can build easily..)

How can I fix this?

Thanks! Yoni.

Product Version: Not Selected
Tags:
more ▼

asked Dec 27 '14 at 05:34 AM in Bug Reports

avatar image

YoniBE
39 10 13 15

avatar image YoniBE Dec 27 '14 at 07:03 AM

Edit: Now I found that I have the same problem in every project. Even new projects that I create.:\

avatar image DotCam Dec 27 '14 at 06:28 PM

Hi there,

How long are you waiting before forcing the engine to quit? I see this on my pc as well when I am building the lighting, it looks like it is frozen but it is still running in the background. The lighting is built using your CPU instead of the video card, so it depends how fast/new of a processor you have.

Right click on the taskbar and select Task Manager before building the lighting and then start building to see if your CPU usage is going to 100% while building the lighting. If it does reach 100% and sit there then your editor will appear to freeze until the CPU usage goes back below 100%, but is not actually frozen.

Also check the taskbar buttons for "Swarm Agent" and double click to open it while the lighting is being built. So long as the progress bar is increasing your editor is not actually frozen, it is just overloaded.

So try giving it some time, larger levels can take hours but you's sounds like it should only take a few minutes. Hope that helps!

avatar image YoniBE Dec 27 '14 at 06:55 PM

Hi! I tryed to leave the build for all the night (12 hours), and it still was on 0%. The CPU doesn't rich 100%.

avatar image DotCam Dec 27 '14 at 07:16 PM

What version of the editor are you using and is it compiled from source or through the launcher?

I'm also moving this question to the Bug Reports section since this sounds like an problem with the Swarm agent instead of a rendering issue.

Does the Swarm agent load up when you start building the lighting? It's a separate program you can find in the system tray while the lights are being built.

avatar image YoniBE Dec 27 '14 at 07:47 PM

I'm using 4.6.1... And 2 days ago the build worked perfectly.. And I will check out the Swarm agent when I will come home.

avatar image YoniBE Dec 28 '14 at 05:25 AM

OK. So I tried to build it again and open the Swarm folder and I don't see there any application that I can open..alt text

The EXE file can't open... I opened it and it show me an error message that I don't have file in my system.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok. So this is strange but I didn't do anything and now when I come back from school the build start work again.. XD I don't know what was the problem and how it fixed because I really didn't do anything to fix it or something... haha

more ▼

answered Dec 28 '14 at 11:58 AM

avatar image

YoniBE
39 10 13 15

avatar image DotCam Dec 29 '14 at 05:17 PM

That is really strange...

It's good to hear it's working for you again though! I will mark this question as resolved for now, but if you run into any further issues please feel free to re-open this question with some more info.

Thank you!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question