x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

SIGSEGV UE4.6.1 OSX 10.10.1 on Play

Every time I Play in "Standalone Game", or "Mobile Preview" I get a crash upon starting which I've included as a gist here: https://gist.github.com/schetle/29ce5aebb0e3b89411c2

It works fine in PIE, it also works fine when running -Mac-DebugGame.app

Product Version: Not Selected
Tags:
more ▼

asked Dec 28 '14 at 12:12 PM in Bug Reports

avatar image

schetle
76 6 9 16

avatar image Ben Halliday STAFF Dec 29 '14 at 08:45 PM

Hi schetle,

I wasn't able to reproduce any crash using Standalone Game or Mobile Preview in 10.10.1. Does this happen in a new project as well, or only in your current project? Please zip and attach the crash log for the project.

https://wiki.unrealengine.com/Locating_Project_Logs

Thanks!

avatar image schetle Dec 30 '14 at 02:11 AM

Seeing as how every time I tried to attach the zip, this upload procedure gives me "No such upload" - I've included it as a dropbox link here: https://dl.dropboxusercontent.com/u/140945/CrashReport-UE4-Ze-pid-30690-77916bbd9b4ba067f17e868364793719.zip

In the editor log (the magic line, right before the dump), it looked like it was being caused on the initializer for my Character class. I've since changed the initializer and don't get the crashes anymore. The only things I changed had to do with playing around with default settings on the capsule and mesh components, such as simulate physics. I can't imagine a typo would've gotten through the compile process, but I've seen weirder things.

avatar image Ben Halliday STAFF Dec 30 '14 at 07:20 PM

Do you know specifically what you changed in your initializer that stopped the crashes from occurring?

avatar image schetle Dec 31 '14 at 06:50 AM

My train of thought was that I could default the rotation of meshes generically on all of my Character subclasses (Player, NPCs) - as all of their meshes were centered in the capsule, and their rotation was off by 90 degrees. I wanted to do this so I didn't have to change the blueprint subclasses if it could be done generically on the backend.

I had set the Mesh component to a negative Z on location, and slightly different rotation on the Character initializer.

I tried duplicating what I did before, and while it's a separate issue that my values aren't sticking when I blueprint off my Character class - it's not giving me the desired error when I Standalone play or Mobile Play.

In retrospect, I probably should've made a copy of my project that was causing issues and worked on a different version since I wasn't sure where the error was happening. I wasn't aware of the particular crash log that tipped me off to it being the initializer, or I would've been able to identify it easily.

Next time! shakes fist

avatar image Ben Halliday STAFF Dec 31 '14 at 02:01 PM

Hah, that's okay. If you see that crash again, let us know what code caused it if you can. Glad you got it fixed, though!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi schetle,

Thanks for letting us know that changing the initializer fixed your issue. If you continue to experience crashes in the Standalone game or Mobile preview please hit the "Submit" button on the Crash Report pop up window and let us know by updating this thread.

more ▼

answered Dec 30 '14 at 07:28 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question