Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4.6.1 "Externally Referenced" on basic map

I have a basic map with a landscape and a very simple material applied to it (Base Color with a Constant3Vector). The editor complains about external references when I do a Map Check, and any time I deploy to a device or other actions. The material I'm talking about here is a brand new material I created in my project, and it's path is /Game/Materials/M_BasicColor

  • If I remove the material from the landscape - the landscape warning goes away.

  • If I duplicate the material in Content Browser, assign the duplicated material to the landscape WITHOUT SAVING, the warning goes away. However, as soon as I click "Save All" - the warning comes back.

Warning Landscape_0 Landscape /Game/Maps/Marl.Marl:PersistentLevel.Landscape_0 : Externally referenced

alt text

Product Version: Not Selected
more ▼

asked Dec 28 '14 at 01:06 PM in Bug Reports

avatar image

76 6 9 16

avatar image TJ V ♦♦ STAFF Dec 29 '14 at 05:20 PM

Hi schetle,

I haven't been able to reproduce what you are seeing. Could you create a test project with the error and post a link here to download it here?

avatar image schetle Dec 30 '14 at 02:05 AM

The warnings aren't present when I migrate the map. The warnings also aren't present when I copy the entire project to a different directory. Corrupted somehow?

avatar image TJ V ♦♦ STAFF Dec 30 '14 at 04:39 PM

It's possible. A project corrupting like that is pretty rare but it has happened. It sounds like it could be some sort of referencing error, which are generally hard to track down and fix. If copying the project to a new directory works, I would suggest going with that workaround.

If it happens again or if you receive a similar error, please post back here and let us know.



avatar image JBernal Jan 04 '16 at 04:42 AM

Having the same problem on a project migrated from 4.9 to 4.10. I tried replacing the borked items with new ones but then get the same errors. A build from the same folder contents works fine on a mac, with no errors on editor map load, no errors on compile, no errors on build. A build from the same folder contents works on the initial map loaded from the exe on a PC, but fails to load new maps (resets current map instead). UE editor gives you a handful of "externally referenced" errors on map load. No errors on compile or build. PC side is where I am getting the errors. Mac side seems content.

avatar image JBernal Jan 04 '16 at 04:53 AM

PS I tried the renaming-folder trick but it did not fix the problem.

avatar image Udo May 31 '16 at 07:31 PM

When I migrated form 4.10 to 4.11 with my project UE4 named the copy with a " 4.11" suffix. Please not the space before the version.

I suppose UE4 has problems when the path to the project contains spaces. When I renamed it so that the space was removed I could open my project without warnings.

avatar image acxsasx Jun 14 '16 at 01:13 PM


I have sub levels to my persistent level. The only static meshes that gave me the external error were the ones on the persistent level. I have a sub level for the infrastructure. Once I moved the items giving the error to the sub level AND did the renaming project thing, the errors are gone.

Yet...I still get the pop up box saying there is still a problem, yet nothing on the map check of the Message Log tab. Tried making each level current and saving. Exited the Editor. Still get the message box once, but nothing shows in the map check.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Simply rename the folder, run the project, rename folder to previous name again, done.

more ▼

answered Feb 18 '15 at 12:24 PM

avatar image

387 22 39 53

avatar image Stormrage256 Feb 20 '15 at 11:48 AM

Thanks a lot man, that fixed it for me.

avatar image Omberone Feb 25 '15 at 10:04 AM

Worked for me too

avatar image DamirH Jul 06 '15 at 10:26 AM

I can't seem to get this to work. Do you mean to rename the project folder or the map folder? Do I open up the faulty map when I open up the project? Nothing I do seems to work.

avatar image TJ V ♦♦ STAFF Jul 17 '15 at 12:42 PM

Hi Benjiko99,

Would you have time to go into a little more detail on your answer to help DamirH and other users?

avatar image Naveed Aug 31 '15 at 09:57 PM

Nailed it. How bizarre. In my case I renamed the project directory. Opened the project. Saved it. Closed it down. Changed the project directory name back to what it used to be.

avatar image spyro Sep 17 '15 at 08:14 AM

Yes, that did it (WTF).

avatar image JonathanADaley Sep 18 '15 at 09:32 PM

I had the "externally referenced" warnings today, and the fix of closing the Editor, changing the project folder name, opening the project, closing the Editor , then changing the project folder name back, and reopening the project; worked to fix the issue.

avatar image Spoondog Oct 04 '15 at 11:02 PM

The procedure that JonathanADaley mentioned, worked for me too. What I can add is that I had upgraded to 4.9.2 from 4.8.3 using the "open a copy" method as recommended by Epic. The assets the editor were moaning about were a StaticMeshComponent, a SkyLightComponent and an AbstractNavData (the level is basically just a cube with a couple of lights and a playerstart).

avatar image oxygencube Oct 09 '15 at 03:43 PM

This worked for me as well. Moved from 4.8 to 4.9.2.

avatar image John Alcatraz Oct 20 '15 at 10:45 PM

I got these warnings when moving from 4.8 to 4.9 and now again after I converted a copy of my project to 4.10P2... Will I now have to do the project folder renaming after each engine update? Will there be a fix for that at some point?

avatar image TJ V ♦♦ STAFF Oct 22 '15 at 02:47 PM

Hey John,

This is a known error if you are cloning your project and then converting that cloned project in place. Is that the workflow that you are using?

Instead try to open the project with the new engine version and then choose 'Open a Copy'. This is the suggested workflow.

To get this error you must convert a project in a way that we do not recommend, so this error does not have a planned fix.

avatar image Kenomica Nov 11 '15 at 04:58 PM

Just wanted to add - this still happens using the recommended method.

I started a project in 4.9, then opened 4.10 - tried opening my 4.9 project, and chose "Open a Copy"

Lots of external reference errors. I managed to fix it with the method above (project folder renaming) but this is not a problem that is only affecting those converting or using the "not recommended" method.

avatar image vnhllsng Nov 16 '15 at 04:32 PM

Yup. I also got this issue even though I used the recommended method (tried open a 4.9 project in 4.10 and chose "Open a Copy").

Renaming project folder helped.

avatar image Roel Nov 20 '15 at 02:59 PM

Also got the same issue going from 4.9 to 4.10. Solved by renaming the folder as well.

avatar image jtsmith Jan 23 '16 at 02:27 AM

I get external error for anything placed inside any of my maps. Thing is, this is a fresh 4.10.1 project, not upgraded. The only thing I can think of is it's a source controlled project. In my main test map, the meshes/materials were migrated from a previous (older) project and the other map is being worked on and updated by someone else on the project. I have not yet tried the renaming of my folders yet to see if this solves the issue; this, I think, will prove a challenging task with the source control but I will give it a shot.

With these errors coming on a new, non-upgraded project, proves that this is not a result of not following Epic's recommended upgrade procedures. There is something else going on and it should be looked at deeper. I have not tried to build my project yet with all these warnings but I have a bad feeling. I will be trying a build/package this weekend just to test.

alt text

externalerror.png (342.0 kB)
avatar image JBernal Jan 23 '16 at 07:31 AM

I am not using source control, yet. Same problem.

avatar image E.B.B. Apr 01 '16 at 07:11 AM

I experienced this yesterday, opening my project made in 4.10 with 4.11. I did choose "Open a copy", but still got an external reference error. Have not tried the workaround of renaming the project, but will do when I get home from work.

avatar image spyro Nov 26 '15 at 09:12 AM

Can confirm this, issue remains with 4.10 (but workaround works also)

avatar image sick Jan 11 '16 at 09:36 PM

Ridiculous but yea... it's still present in 4.10.1.

avatar image ShortStuf7 Feb 09 '16 at 05:45 AM

You rock. Thank you!

avatar image SememeS Mar 02 '16 at 09:37 PM

Thank you!

avatar image shanyue Apr 08 '16 at 09:00 PM

Thank you!

avatar image MarkcusD Apr 24 '16 at 12:41 AM

Thanks for the workaround!

avatar image StMalk May 11 '16 at 01:33 AM

Doesn't work. I rename the folder, launched the project. Saved it. Renamed it back, launched again - this error still exists.

avatar image Distul May 27 '16 at 10:45 PM

On 4.11.2 I broke my project and had to move contents folder to a new project, which resulted in this error. Using this fix worked. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

FYI, it seems to be the project folder. That's what fixed it for me.

more ▼

answered Aug 06 '15 at 05:44 PM

avatar image

48 11 13 17

avatar image Drixil Aug 08 '15 at 08:43 AM

Wow really... This was what it suggest when posting this bug AGAIN... However this is the problem I have and why that option is not by any stretch a fix or work around. A: I hate clutter in my content directory and it is just sloppy and unprofessional to have every asset from the marketplace hanging out leaving its trash all over the place. So I rename said content and move it. If I can't rename the content and put it where I want (which is a chore by itself) there is no point in using the engine.. Its abilities are great and mighty but basic functionality is simply not being there or getting corrected. This is really getting old after a year and a half of version after version having the same broke content browser..

Why are we moving on from 4.8 to 4.9 if 4.4. 4.5, 4.6, 4.7 and 4.8 all have the same basic functional issues in the content browser flaws? Maybe you are moving to fast. This engine blows away just about everything out there... You can take your time and get it right you know.

avatar image CyanBalloon Aug 31 '15 at 09:20 PM

You are quite right about that. Content renaming, redirectors, deleting assets and things like that are extremely fragile in ue4. These are things that should be fast, easy and bugless. This is basic functionnality and it is extremely bad in this engine.

avatar image RichardB Nov 09 '15 at 09:40 PM

I just found renaming the folder, opening and saving worked for me. I sometimes find these things annoying, then remind myself that UE is open source, if I was that frustrated by anything I could go into the source and change it - then the act of thinking of what I would have to do to fix them makes me feel that the work-arounds are just fine :) I've been doing the upgrade "in-place". From now on I'll do it on a copy then just delete the original once I'm happy it converted properly.

avatar image SterlingY Dec 26 '15 at 08:31 AM

This solution worked, but what puzzles me is why has this bug not been fixed? The bug was posted a year ago.

In case anyone at Epic is listening. I copied my 4.9.2 project and opened it with a vanilla build of 4.11, which I converted in place. The warning showed up when the 4.11 version opened.


(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Damn, I've changed name of the folder but it was o ver one week ago and cant remember original name of the folder, is there any way to retrieve it?


more ▼

answered Mar 15 '16 at 05:20 PM

avatar image


avatar image E.B.B. Apr 01 '16 at 07:18 AM

When you create a new project, the project name you choose will be used in many places, like the name of the project folder itself, but also the .uproject file that resides at the root of your project folder.

There's the .sln file, and even your binaries in Projectfolder\Binaries\Win64\ will contain the original project name. I don't know how you have done the renaming though, but you should be able to find the original name, somewhere.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

HI~all。I have another way to fix this problem。

Please try this: Find these two ini in direction like this:YourProject\Saved\Config\Windows” EditorPerProjectUserSettings.ini Editor.ini

Search key word “Content”

you will find some direction obvious incorrect.

Just Replace them to the right direction. MY ie: alt text

That's all~ Hope's help~

fix.jpg (107.6 kB)
more ▼

answered Feb 28 '17 at 08:04 AM

avatar image

1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question