x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android package bug after following documentation

Here is the link to the log file:

http://1drv.ms/1zOPK1h

So I have 4.6 source compiled with a c++ project configured. I went through all of the documentation and instructions to get the Android related files on my box by installing the file: tadp-2.0r8-windows.exe express installation. I verified my device is set to developer mode and was able to see it in the device list.

I then tried to package my project for (development) but I continue to get stuck where it cannot find libraries. I'm not sure if it is because it is looking for them in the wrong place or the libraries do not exist. I tried doing a file search for lcxa_demangle, licudata and licuuc but found nothing. I'm assuming these should be libraries installed as part of the Android package but am not 100% sure. Is there something I missed when compiling my game solution and/or project settings?

Any help would be greatly appreciated. I went through various other threads and made sure I only the default Android SDK's installed as there were issues with newer versions I've read.

The only other thing I can think of are my folder structures.

Unreal Engine is in D:\UE4\UnrealEngine\Engine Game is in D:\UE4\UnrealEngine\ciicharm Android SDK is in C:\NVPACK

Also made sure my environment various were set correctly and seemed to be.

Much appreciated, -jeff

Product Version: Not Selected
Tags:
more ▼

asked Dec 31 '14 at 02:08 AM in Packaging & Deployment

avatar image

jeffvoigt
423 19 34 61

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

So this seemed to go away after I ran the setup.bat file again. It probably picked up more files after i installed NVPACK... duh.. =) I guess it should be made apparent that you will want to install the NVPACK before the engine source.

more ▼

answered Dec 31 '14 at 04:47 PM

avatar image

jeffvoigt
423 19 34 61

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question