x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Morph targets makeing edges soft

when i blend my Morph targets on or have an animation which uses them is turns some of my hard edges soft. could this be a problem with my FBX export settings from maya? as i understood it the morph target is meant to have the same vert normals as the base mesh. any help would be fantastic. thanks, Finn

Product Version: Not Selected
Tags:
more ▼

asked Dec 31 '14 at 07:04 PM in Using UE4

avatar image

r8ivy
194 9 11 27

avatar image Randomself Jul 27 '15 at 03:04 AM

Hi Finn, did you ever find a fix for this issue? I'm experiencing it as well. I've tried various things. Locking and unlocking the normals on the affected geometry, toggling each of the export settings and testing but haven't been able to get around it. Thanks.

avatar image jmalaska Jul 28 '15 at 01:14 AM

Any chance you could post the Maya files? It would be easier to debug.

avatar image Unreal1000 Apr 10 '16 at 09:00 PM

Im having the same problems in 4.11. Morphs look great in Maya. In UE4, they deform my character.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

as i understand it this was just a limitation of blend shapes in the engine. best to make the original mesh be all soft edged to begin with and then it will be consistent when blend shaped. that being said i see on road map that this has been fixed in 4.12. look forward to trying it :)

more ▼

answered Apr 12 '16 at 01:44 PM

avatar image

r8ivy
194 9 11 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I ran into this issue as well. All I had to do was select my mesh, and unlock the normals. You may need to re-soften or harden certain faces, but that fixed the issue for me.

more ▼

answered Feb 28 '17 at 12:39 AM

avatar image

aalberto
0

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I resolved this by checking "Preserve Smoothing Groups" in FBX import settings, you could try that.

more ▼

answered Jul 30 '15 at 08:48 AM

avatar image

Randomself
0 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

if anyone is still searching for an answer, this is what worked for me.

i wanted to import a low poly model, mine craft character rig, into unreal engine and was having issues with morphs and blend shapes... i used blender to export FBX, settings of the export that worked for me are shown in the image below:

link to the image!

more ▼

answered Jun 27 '18 at 09:54 PM

avatar image

abdulmoizmehmood
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question