x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't change UMG Text font size - why?

When i try to change font size under Appearance section, it changes - but after clicking Compile it goes back to original size. Same thing is happening when trying to change, for example, from Bold to Regular. Any clues?

Product Version: Not Selected
Tags:
more ▼

asked Dec 31 '14 at 10:23 PM in Using UE4

avatar image

Slavq
2k 153 153 204

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Argh, solved it right after posting this question: "AutoKey" in animation timeline was turned on and it caused key adding from edited values :) BTW. There should be a possibility to 'exit' animation editing mode, it might cause some confusion right now. Happy New Year!

more ▼

answered Dec 31 '14 at 10:29 PM

avatar image

Slavq
2k 153 153 204

avatar image TorQueMoD Jul 01 '17 at 09:12 AM

I'm having the same issue but your solution makes absolutely no sense to me. Animation timeline in a widget blueprint? Or were you using your font in a different scenario cause I'm having this problem inside my widget.

avatar image Slavq Jul 01 '17 at 09:16 AM

I don't know if UMG looks the same as it was in Jan 01 2015, but apparently there was an 'AutoKey' button or checkbox somewhere near UMG timeline. There was a timeline for editing UMG widget animations at the bottom of the UMG editor. Turning it off and deleting all previously created keys solved that.

avatar image TorQueMoD Jul 01 '17 at 09:22 AM

Interesting... I didn't even notice the timeline until you mentioned it :P It says No Animation Selected and it's not creating any keys... Very strange. Here's a video showing what's happening to me: https://youtu.be/oHx8txLLMWM

avatar image Slavq Jul 01 '17 at 09:26 AM

Hmm, so it looks like it's a different thing, probably some new bug. Maybe create a new bug report for it.

(comments are locked)
10|2000 characters needed characters left

I just figured it out. For some reason the font was getting smaller the more lines of text there were so I just typed in "I wonder" and it showed at a large font size. This got me thinking and it turns out it was due to the fact that I had the text block inside of a Scale Box which was throwing everything out of wack. I removed the Scale Box and just anchored the text block to full screen and the problem is solved. Thanks for trying to help though Slavq. Between the two of us maybe we'll help some other people avoid the same issue in the future :)

more ▼

answered Jul 01 '17 at 09:42 AM

avatar image

TorQueMoD
1.1k 81 110 142

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question