x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG Widget crashes on compile

I've created a UMG Widget, and the Editor crashes every time I click to Compile it. I believe it is the same error each time.

Here is the callstack from the Crash Reproter:

Access violation - code c0000005 (first/second chance not available)

UE4Editor_UMGEditor + 1295505 bytes UE4Editor_UMGEditor + 1469887 bytes UE4Editor_UMGEditor + 1063486 bytes UE4Editor_UMGEditor + 780609 bytes UE4Editor_UMGEditor + 1542044 bytes UE4Editor_UMGEditor + 1380179 bytes UE4Editor_Kismet + 992204 bytes UE4Editor_Kismet + 1007276 bytes UE4Editor_Engine + 600292 bytes UE4Editor_UnrealEd + 9881830 bytes UE4Editor_Kismet + 727159 bytes UE4Editor_Kismet + 992849 bytes UE4Editor_Kismet + 1007926 bytes UE4Editor_Slate + 588774 bytes UE4Editor_Slate + 1535133 bytes UE4Editor_Slate + 1030727 bytes UE4Editor_Slate + 1037049 bytes UE4Editor_Slate + 1435577 bytes UE4Editor_Slate + 2116506 bytes UE4Editor_Slate + 2296435 bytes UE4Editor_Slate + 432060 bytes UE4Editor_Slate + 160583 bytes UE4Editor_Slate + 832224 bytes UE4Editor_Slate + 770598 bytes UE4Editor_Core + 2484713 bytes UE4Editor_Core + 2400763 bytes UE4Editor_Core + 2489275 bytes UE4Editor_Core + 2387186 bytes user32 + 9268 bytes user32 + 8855 bytes UE4Editor_Core + 2490486 bytes UE4Editor!FEngineLoop::Tick() + 3434 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2193] UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:131] UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202] UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Product Version: Not Selected
Tags:
more ▼

asked Jan 02 '15 at 09:04 PM in Blueprint Scripting

avatar image

JonathanADaley
644 37 49 78

avatar image Everynone Jan 12 '15 at 09:52 AM

Any solutions to this problem? I keeps happening on 4.6.1 when selecting UMG widget elements and compiling. Project runs fine after restarting, though.

avatar image Moss Jan 12 '15 at 09:58 AM

Could you reproduce it using a source build compiled in debug mode?

avatar image Everynone Jan 12 '15 at 10:50 AM

I have not tried. I can confirm it was present in 4.5.

Reproduction of this issue in a new project / blueprint is difficult. This never happens in newly created widgets. The widgets that develop this behaviour can be very simple, though - I got to a point where a Sizebox and an Image (no variables or references) would crash 100%.

The worst/best part is that the project still runs fine, but one can no longer edit the widget. The widget's Graph can be compiled, but compiling the Designer after selecting any of its elements (the widget does not even gets flagged as dirty) results in the error mentioned by the OP.

Also, a new widget recreated from scratch with the same elements may or may not crash. Seems pretty random.

Waiting for 4.7 (or feedback on this crash) rather impatiently. :|

avatar image JonathanADaley Jan 12 '15 at 02:31 PM

It's been a seemingly random occurrence for me as well. I've gotten into the habit of saving my UMG widgets, and doing a Save All, before compiling a widget; just so I don't lose any work.

I have also noticed that the crash happens when compiling after making changes in Designer mode; changes in Graph mode will compile just fine.

avatar image Everynone Jan 14 '15 at 10:22 PM

This behaviour can be somewhat mitigated by saving (as you said) and closing the Designer window if switching to the Graph helps little.

Still, this issue persists for now. I tried avoiding direct blueprint communication and any circular references. It rarely helps, though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question