x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crash on launch on Mac

Installed UE4 on my Macbook Pro, crashes on launch.

Specs of Laptop

Macbook Pro Retina 13" (Late 2013)

128GB SSD

4GB RAM

Iris graphics (1.5GB)

OSX Yosemite fully updated (as of 4th January 2015)

I've tried 4.6.1, 4.5.1 and even the 4.7 preview.

The log is the same for each version. It appears to not be able to create an OpenGL context.

Pastebin of the minidump http://pastebin.com/uDm5u09w

Product Version: Not Selected
Tags:
more ▼

asked Jan 04 '15 at 07:10 AM in Bug Reports

avatar image

Sudorossy
1 1 2 4

avatar image Ben Halliday STAFF Jan 05 '15 at 07:28 PM

Hi Sudorossy,

How far do you get before the crash occurs? Are you trying to open from the Launcher or have you compiled from source using GitHub? Are you able to get to the Project Browser to create a new project, or does it crash before then?

Please copy/paste the information from the Apple Menu > About This Mac (minus the Serial Number). Thanks!

avatar image Sudorossy Jan 05 '15 at 07:34 PM

Hi Ben, thanks for the reply.

I open from the launcher, on clicking "Launch" either from the main screen or from "Library", the launcher minimizes and a second later the crash log comes up.

I can't create any projects.

Info from "About this Mac" OSX Yosemite Version 10.10.2 MacBook Pro (Retina, 13-inch, Late 2013) Processor 2.4 GHz Intel Core i5 Memory 4 GB 1600 MHz DDR3 Graphics Intel Iris 1536 MB

Currently my Display options are on "more space", but I get the same error if I leave the display options on default.

avatar image Ben Halliday STAFF Jan 05 '15 at 08:40 PM

Please zip and attach the logs found in this location:

~/Library/Application Support/Epic/Unreal Engine/4.X/Saved/Crashes/CrashReport-ProjectName/

Note that /Users/yourusername/Library is invisible. While in the Go menu, hold the Option key and select Library to open it in a Finder window.

avatar image Sudorossy Jan 05 '15 at 08:46 PM

Here's the attached crash reports. There were a few folders in that folder (I assume from the multiple times I've started the program), so I zipped them all.

crash reports.zip (143.1 kB)
avatar image soccerfield24 Oct 05 '17 at 08:30 PM

Installed completed .... When I clicked launch on Epic Game Launder, it crashes right away. I need help with this. Thank you.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

10.10.2 is a pre-release build, nothing has been tested against it, but even then that's an odd error to be seeing. It suggests that OpenGL can't create the context, but I can't reproduce that here on my machines.

As a first step if you can try running 10.10.1 (the current public build of Yosemite) just in case it is a 10.10.2 issue.

more ▼

answered Jan 06 '15 at 04:08 PM

avatar image

marksatt-pitbull STAFF
1k 31 4 44

avatar image Sudorossy Jan 06 '15 at 09:22 PM

Thank you! I had no idea it'd kept updating to beta versions after Yosemite released.

This solved my launch issue. Thanks again.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question