x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem with UE4 material editor layout

I have a problem with material editor. It shows up without any content but the toolbar, so I cannot operate on any material and basically use the UE4. Window menu shows all the stuff enabled (checked): toolbar, viewport, graph, etc. I cannot uncheck them. Also restore layout option does not fix my problem. I use 4.6.1 version (downloaded .tar.gz) on OpenSuSE linux 13.1.

Product Version: Not Selected
Tags:
more ▼

asked Jan 04 '15 at 06:20 PM in Using UE4

avatar image

tomecki
6 1 4 4

avatar image TJ V ♦♦ STAFF Jan 05 '15 at 07:12 PM

Hi tomecki,

Could you provide some screenshots to show us exactly what you are seeing?

avatar image tomecki Jan 05 '15 at 10:34 PM

The issue also happened on 4.7 version on different machine with the same OS.

avatar image tomecki Jan 05 '15 at 09:06 PM

The screenshot is included. I cannot make screen from menu (idk why), but all the options in window (viewport, graph, details etc) are checked (enabled), and I cannot uncheck them. The failure is not permanent. When I close this project and create new one the material manager works ok. However it is breaking at some moments, which I cannot determine, and once gets broken in some project it will remain broken. I have also determined that even if material manager works ok, I cannot uncheck (hide) parts of layout, I can only show them (check). To hide I must close all the tabs, and then the element will dissappear from layout and will be marked unchecked.alt text alt text

avatar image TJ V ♦♦ STAFF Jan 05 '15 at 09:34 PM

The only way to disable a window is by closing the window itself, this is intended functionality. However, the windows should not close automatically and remain 'checked' in the Windows dropdown menu.

Could you post your dxdiag (system info)?

https://answers.unrealengine.com/questions/12363/how-do-i-report-a-bug.html

avatar image tomecki Jan 06 '15 at 02:29 PM

I am sorry but there is no dxdiag on linux. my uname output: Linux 3.11.10-25-desktop #1 SMP PREEMPT Wed Dec 17 17:57:03 UTC 2014 (8210f77) x86_64 x86_64 x86_64 GNU/Linux

nvidia-smi --query:

==============NVSMI LOG==============

Timestamp : Tue Jan 6 15:19:09 2015 Driver Version : 340.65

Attached GPUs : 2 GPU 0000:01:00.0 Product Name : GeForce GTX 560 Ti Product Brand : GeForce Persistence Mode : Disabled GPU UUID : GPU-0b1d8dbb-c23e-7439-f9bd-13388491af78 VBIOS Version : 70.24.2E.00.02 PCI Bus : 0x01 Device : 0x00 Domain : 0x0000 Device Id : 0x120010DE Bus Id : 0000:01:00.0 Sub System Id : 0x35151458 Performance State : P0 FB Memory Usage Total : 1023 MiB Used : 173 MiB Free : 850 MiB Compute Mode : Default Temperature GPU Current Temp : 47 C


If you want any additional info, please let me know.

avatar image TJ V ♦♦ STAFF Jan 06 '15 at 04:23 PM

I've roped in one of our developers that is a bit more familiar with the Linux OS. We hope to have a suggestion for you soon.

avatar image tomecki Jan 06 '15 at 02:54 PM

I have tested this a little and have packed zip file containing the whole project that causes the issue. Unfortunately it is 640MBytes. Please let me know how if this can be helpful to you, and if it is, please give me instructions how to get it to you.

avatar image RCL STAFF Jan 06 '15 at 04:46 PM

Are you saying that this only happens with a particular project? Can you repro the issue from scratch?

avatar image tomecki Jan 06 '15 at 04:59 PM

Actually it happened with a number of projects, and I could not find the relation with some action that could cause it. However once the project gets "broken" it will remain broken even after the whole computer reboot. I always start with a new blank project: desktop/console maximum quality with starter content

If I create a new project it will work ok, until something breaks. My actions were adding some FBX models, adding landscape, sculpting, and changing the objects locations. However I cannot find a connection between a specific action and the moment that project gets broken.

I can provide the project that is "broken" and lt ALWAYS causes the bug. This is currently the only way I know to reproduce the bug: - start Editor - load my project

I also noticed that I cannot rotate my view after loading the broken projects. I mean when I normally draw viewport with RMB (or LMB) pressed i can change my orientation. I got the state when I can only move forward/backward with LMB, while RMB does nothing. Dragging with CMB (3rd button) works normally as it should: my camera is moving.

I thoght it would be helpful for you to see what is going on when loading it.

UPDATE: I realized that most of 640MB of my project is located in StarterContent directory. However after I tried to erase some of it I realized that my Content Browser shows that Starter Content is empty. I checked twice and THERE ARE files in this directory. Weird...

avatar image RCL STAFF Jan 06 '15 at 05:03 PM

You may try using promoted (or even master) branch and see if this has been improved since then. While I don't remember that particular issue, 4.7 code is much better at handling Linux windows, so there are chances that it "went away".

avatar image tomecki Jan 06 '15 at 11:27 PM

I tried "promoted" version, and it is just the same. Empty material editor, no assets in content browser, and no posibility to change the angle of view in viewports. I really think that problem is located somewhere in my project. As I said I can provide it, but its 640MB.

avatar image tomecki Jan 07 '15 at 01:12 AM

Update - I made new screenshot, as in 4.8 (promoted) the screengrabber also shows the menus. As you can see there are missing elements in material editor. On the left side the content browser is empty, but I am 100% sure that the directory i chose DOES contain textures. Also - I cannot rotate the view, so I can only watch the scene from this angle. What is interesting that I can change orientation while playing in editor, but again I cant rotate when playing with simulation option. This is really weird...

[1]: /storage/temp/25882-unreal-fail-02.png

unreal-fail-02.png (603.2 kB)
avatar image tomecki Jan 12 '15 at 08:13 PM

Sorry for bothering you, but I wonder if there are any ideas according to this bug? It is blocking me from further development...

avatar image RCL STAFF Jan 12 '15 at 08:47 PM

No idea at this point alas. Try enabling directory watcher (which is commented out on Linux because it needs more love) and see if it helps the content browser (be wary of crashes caused by the watcher though).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question