x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

3DS max fbx import no smoothing groups for skeletal mesh

When importing a skeletal mesh from FBX file I get the following error

Warning Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file. Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

I get this even though I have checked the smoothing groups in the 3ds max export option. Also I can see Artifacts on the meshes. with default material the mesh appears as if flat shading was used :( .

The same problem existed with UE3 . importing PSX worked fine in UE3 but fbx gave the same error.

I read that for static mesh objects it can be fixed by the recompute normals check box is there something similar for skeletal meshes?

Product Version: Not Selected
Tags:
more ▼

asked Jan 05 '15 at 03:22 PM in Using UE4

avatar image

Commander Shepard
797 62 82 219

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey RubenCG,

If you would like to import your model without smoothing groups, uncheck both options within the Export/Import windows. Within your Autodesk program, uncheck the 'Smoothing Groups' option, and within the import window of UE4 uncheck the 'Preserve Smoothing Groups' option.

These two places should disable your Mesh from generating smoothing groups where you would not like to have them. Let me know if these suggestions resolved your issue, or if you need further assistance.

Cheers,

Andrew Hurley

more ▼

answered Jun 22 '15 at 01:26 PM

avatar image RubenCG Jun 22 '15 at 02:57 PM

It works great!, I think that was the only thing I didn't try yet xD. Thank you very much.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Commander Shepard,

Do you have smoothing groups on your Mesh inside of the 3d Modeling application i.e. Max or Maya?

Also what Binary version are you exporting your .FBX as? 2013 or 2014?

Thanks,

Andrew Hurley

more ▼

answered Jan 14 '15 at 10:45 PM

avatar image RubenCG Jun 18 '15 at 10:37 AM

Hello!, I have the same problem. I exported a skeletal mesh to .FBX 2014 from 3Ds max with "smoothing groups" and "tangents and binormals" activated. The mesh has smoothing groups. But the same error message appears when I import in EU4 4.7 or 4.8. I have read everything about and have tried many things but I cannot fix it.

Any help ?. Thanks.

avatar image AndrewHurley Jun 18 '15 at 02:17 PM

Hey RubenCG,

Would you mind providing me with some screenshots of the exporting and importing process you are taking so I can check your steps?

If we cannot determine the cause of the issue, you can provide me with the .FBX file to test with on my end.

Let me know if you have any other questions or need additional assistance.

Regards,

Andrew Hurley

avatar image RubenCG Jun 22 '15 at 07:39 AM

Thanks for answering !. I'll explain my problem:

problem_smooth_01.jpg - This is the model with Smoothing group Hard.

problem_smooth_03.jpg - Import options in UE4.

problem_smooth_02.jpg - The result in EU4, Smoothing group Hard is ignored.

alt text

alt text

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question