x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media Framework on Android

I've seen various posts confirming that startup movies aren't supported on Android yet, and I was wondering if this extended to video playback in-game as well using the Media Framework. I've tried to play a movie both as a material in-level as well as UMG, but while it works great on PC it isn't playing on Android.

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Jan 05 '15 at 07:19 PM in Packaging & Deployment

avatar image

fepark
6 1 1 3

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Startup movies and the Media Framework are supported on Android for 4.0 and up starting with Unreal Engine 4.7. The movies need to be in mp4 format and placed in your project's Content/Movies folder.

For startup movies, just place the mp4 in the folder and add it to the Startup Movies array in the Movies section of the project settings. You may also want to turn on Wait for Movies to Complete if you want the movie to finish before showing the startup map (otherwise it will stop as soon as the map is finished loading).

more ▼

answered Mar 27 '15 at 03:22 PM

avatar image

Chris Babcock STAFF
1k 11 110 35

avatar image Kayhan Ygh Dec 10 '15 at 02:26 PM

Hi Chris! I have moved all my movies into movies folder in the content folder and all movies are mp4 1280x720 , The start up movie is working properly but the movie that is used in UMG witch is a media texture is not working on android. I'm using UE 4.9 and I have packaged the game on Galaxy note 3 and s5 same result on both of the devices. What could be the reason? Thanks.

avatar image Chris Babcock STAFF Dec 10 '15 at 05:38 PM

In the media material try setting it to unlit and connecting the texture sampler output to emissive input. Also, make sure you actually select play on the media player. I have recently added some optimizations to the Android media player in game and fixed an issue with pause not working for 4.11.

avatar image Kayhan Ygh Dec 11 '15 at 06:54 AM

I have changed the material type to unlit and checked and unchecked fully rough option . But still getting the black screen. It's working and playing fine on windows though , I don't really know what I'm missing?

avatar image Chris Babcock STAFF Dec 11 '15 at 05:08 PM

Does the same mp4 work as a startup movie? They use the same player code so this is next thing to check. If so, make sure the path in the media player asset uses a relative path instead of absolute. That means it should be ./Movies/mymovie.mpg, NOT c:\myproject\Content\Movies\mymovie.mpg which it may be if it was imported. I have another check in 4.11 that fixes up this kind of error if encountered instead of just giving a black screen.

avatar image Kayhan Ygh Dec 11 '15 at 06:12 PM

Well! That did the trick! Changed the movie address and it worked! Although I've tested out with unlit material and haven't test it out with the UMG yet. Thanks Chris!

(comments are locked)
10|2000 characters needed characters left

Hi there! I did everything you suggest here, but it still doesn't work for me, not even in PC launch mode...

Is there a complete workflow I can follow to see if I missed something? Thank you so much.

EDIT: I use UE4 10.2

more ▼

answered Feb 04 '16 at 01:20 PM

avatar image

CarlosRBSTSN
21 2 5

avatar image Chris Babcock STAFF Feb 04 '16 at 11:02 PM

Hi Carlos,

For a startup movie:

  1. Create a Movies folder in your project's Content folder

  2. Copy your mp4 into this folder

  3. In Editor, open Project Settings and select Movies tab

  4. Click on the + on Startup Movies to add an element, then click expand it to see the element

  5. Click on "..." to browse for your mp4

  6. Check "Wait for Movies to Complete" if you want the movie to play completely before level is shown; level load complete stops playback so unless you have a large level you'll need to check this to see it

  7. Check "Movies are Skippable" if you want to allow tapping on the screen to stop the movie playback early

  8. Package for Android (ETC1 works on all)

  9. Install on device and play

For media framework:

  1. Create a Movies folder in your project's Content folder

  2. Copy your mp4 into this folder

  3. The editor should automatically create a Media Player in this folder in the content browser with the name of the mp4. If not, right click in the movies and select create miscellanous->media player

  4. Double-click on the media player to open it for editing

  5. Fix the File or URL source path (it is hardcoded by default) to ./Movies/[my mp4 file]; you can also click on "..." and select it and it will store the relative path

  6. Save it and return to content browser

  7. Right click on the media player and "create media texture"

  8. Right click on the media texture and "create material"

  9. Double-click on the material and connect the texture sampler emissive color and save

  10. Attach the material to a static mesh

  11. Media->Media Player->Play BP node can be used to start the movie (attach to BeginPlay in level blueprint or in a UMG widget, etc). Connect the media player to the node.

  12. Package for Android (ETC1 works on all)

  13. Install on device and play

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question