x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Importing FBX - Textures won't work

Hi,

I'm very new to UE4 and I might just lack the knowledge of how to correctly import FBX-files to UE4, but I'm importing the meshes just as the UE4 tutorials say but it never works. Not a single FBX or OBJ file has ever been imported with working textures. I've tried roughly 15 - 20 different models, all import fine and so does the textures but the previews are all white (and the FBX mesh icon and the texture/material icon all have a white asterisk on them).

I've literally scavenged the internet for anyone who might have a solution to this, and I've put in hours to try to fix this already - but my knowledge of UE4 is limited and I'd really appreciate any (!) help I could get fixing this.

Below you'll find a screenshot of how the materials and the mesh look in the Content Browser, and how the model look in the Viewfinder after being placed in the world. [Note: This happens to all FBX models I import, not just this one].

alt text

Thanks in advance!

Product Version: Not Selected
Tags:
ue4_issue.png (987.6 kB)
more ▼

asked Jan 05 '15 at 10:13 PM in Using UE4

avatar image

MichelTeixeira
6 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

HI!

I can see how you models look in you 3d program. But, if your model properly textured and in UE in import dialog "Import Material" and "Import Texture" is checked, and you get white material without texture, this means that material assigned in you 3d programm not supported FBX translator (f.e. mental ray material or vray material). Try to check materials in 3d program and fix it, if it does not conform to this guide:

https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/Materials/index.html

more ▼

answered Jan 06 '15 at 07:33 AM

avatar image

svv3dUDN
8.4k 254 42 399

avatar image MichelTeixeira Jan 06 '15 at 10:24 PM

Hi svv3dUDN,

Thank you for the fast reply, much appreciated!

The options "Import Material" and "Import Texture" are checked, yes. None of these models are actually my own - they are all bought and/or freeware & downloaded from CGtrader and other similar sites. I do not have a 3D program installed on my system.

But statistically at least one of the 15-20 FBX's I've imported should have worked, right? I can't separately import textures because in many cases the textures are compressed in to the actual FBX-file.

So, basically, in my case since I'm not a modeler / 3D artist; I can't purchase/download FBX models and use in UE4 - unless the texture & model are separate?

Thanks again for the help!

avatar image svv3dUDN Jan 12 '15 at 03:52 PM

I export model with texture to the FBX file with embed media, and imported to UE4 without problem. Maybe FBX not contain textures or texture format not supported UE4. If you import FBX with embed media, FBXImport plugin create folder named similar base file and with suffix ".fbm" in same place where you placed FBX. And in this folder you can find embed texture, which you can import separatly and attach to shader in UE4.

PS: you can use free FBX tools for check you assets without 3d program http://www.autodesk.com/products/fbx/fbx-review

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi there,

I ran into this as well and thought I'd share my solution. Maybe it's the same for you, maybe not.

All settings were correct on my fbx export, and on my Unreal import, however every time I brought in a mesh, no matter how many different settings I tried would never bring in the textures files along with it. It also completely lost the scale of the UVS within Maya which I discovered after manually trying to add them back.

When looking in the hypershade, all of my files linked up correctly, they were all being pulled from /sourceimages/ in my project.

What fixed my problem, was changing the "/sourceimages/texturename.tga" to "sourceimages/texturename.tga" (removing the first /)

Before exporting everything, when I received the file from an artist, I went through and manually updated the location by typing it in (changing c:\user\whateverlocation\texturename.tga to \sourceimages\texturename.tga) and for some reason, even though they were correctly linked, and showing in Maya, they weren't registering as being there.

Hope this helps

more ▼

answered Aug 02 '15 at 09:28 PM

avatar image

ABurkley
16 2

avatar image twalk1776 Mar 17 '17 at 07:21 PM

Wait, you went through and manually updated the location how? Where is the location of the sourceimages stored?? In the maya file somewhere?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, I'm very new in UE4 too, and have same situation. Maybe, check your source texture type will help.

https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/Importing/index.html

DDS can support with cubemap only.. In my case, source images art all dds, and didn't imported.

more ▼

answered May 19 '16 at 01:13 AM

avatar image

km97khg
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have same problem. when i tries to put a texture on my FBX imported object it just shows an ugly color. Can someone help me??? Please give the help as soon as possible i have only 3 weeks to be done with my school project.

more ▼

answered Sep 13 '16 at 10:23 PM

avatar image

Daciansolgen
1 1 1

avatar image Daciansolgen Sep 13 '16 at 10:26 PM

alt text

This is what it looks like when i tries to put a materia with texture on my object! This is really annoying!!

skärmklipp.png (1.0 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, everyone! I think I found a solution:

When exporting the fbx, you get a file [modelname.fbx] and a separate folder [/modelname] containing its textures. I manually placed the fbx into its texture folder and then imported.

Voila! not sure why this isn't an automated process, but it works!

Hope it helps anyone.

more ▼

answered Dec 06 '16 at 08:51 AM

avatar image

Guillo_Ortiz
1 1

avatar image Lord Pol Aug 25 '18 at 05:10 PM

Thank you. That works : )

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question