x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Disable Collision of Characters

I'm actually a bit shocked that I need to ask such a stupid question here, but it just does not work, I know it should be very simple... I have a character, and I have placed many of them into the level... Once the game starts, they all run to a certain location (move to node in behaviour tree). I have set these collision settings:

alt text

So they are pawns, and they ignore pawns... But still they don't run through each other. Once the first characters reached their move to goal, the others just stupidly run against the other characters, so they clearly collide.

So I guess I am doing something wrong... Maybe Characters always want to collide, no matter what the collision settings are?

Actually, I use this class as a parent for multible childs. The strange thing is, for one child it is working, for another child it is not working... I spent the last 2 hours comparing the settings of these 2 childs and they are absolutely equal :( So why does it work for one but not for another...

Product Version: Not Selected
Tags:
more ▼

asked Jan 06 '15 at 12:39 AM in Blueprint Scripting

avatar image

John Alcatraz
1.3k 61 139 128

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

What is the setting of the rest of your components?

My guess would be you have a capsule or anything besides the plain mesh which does collide with pawns. Could that be the case?

Cheers

more ▼

answered Jan 06 '15 at 01:17 AM

avatar image

Erasio
6k 291 86 293

avatar image John Alcatraz Jan 06 '15 at 01:21 AM

I have the character movement component, an arrow component and the Character mesh. The mesh is set to "Character Mesh" Collision which ignores pawns by default. Then I have 3 additional static mesh components which all have no collision.

avatar image Erasio Jan 06 '15 at 10:46 AM

Just out of curiosity have you tried ignoring everything but world static?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question