x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG: Mouse cursor appear even if disabled

I'm trying to make a custom cursor and as such want to disable/hide the default (windows) cursor. The custom cursor is working fine, but the default cursor just won't go away and I have no idea why.

In my player controller I have ticked off "Show Mouse Cursor" and everything else:

alt text

In UMG, both the Buttons and the CanvasPanel have the cursor option set to "None":

alt text

Yet, as soon as I create my widget, the default cursor is displayed on top of my custom cursor. alt text

It goes away if I click anywhere on screen, except when I click on a Button, then it reappears again. What am I missing here?

Product Version: Not Selected
Tags:
untitled-1.png (8.5 kB)
asdas.png (7.4 kB)
gfdg.png (31.6 kB)
more ▼

asked Jan 06 '15 at 02:16 AM in Blueprint Scripting

avatar image

LEMMiNO
77 7 11 15

avatar image Duncan Dam Jan 06 '15 at 02:27 AM

try to run the game in standalone or new window, maybe what u see is editor cursor ?

avatar image LEMMiNO Jan 06 '15 at 02:32 AM

Didn't work unfortunately. Also tried in full screen and even compiled it.

avatar image Wallhalla Jan 06 '15 at 08:43 AM

I think a default behaviour is overwriding you custom cursor here.

If you look at the Behaviour Picture, is says none, not having the opportunity to look inside myself right now it brings up the idea, if you havnt set a specific cursor, UMG will get the default cursor to show up. Try to bind your custom cursor to that behaviour.

edit: you should somehow be able to tell UMG that your custom cursor is the default one to use

avatar image LEMMiNO Jan 06 '15 at 01:08 PM

There doesn't seem to be any way of doing that. As far as I can tell you can't bind anything other than the predetermined list of common hardware cursors.

alt text

However I found something strange while doing this. The cursor doesn't change from the default one, even if I change every object in UMG to something else. For example if I select "Hand" I still get the standard windows cursor.

alt text

I don't know what this means. Are the cursor settings in UMG having any effect at all?

abc.png (27.0 kB)
cuscur.png (115.6 kB)
(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

It probably wont change anything, but try to set the input mode to UI only, I had a similar problem and that is how I resolved it (and it should not change anything, but it did)

more ▼

answered Jul 02 '15 at 01:39 PM

avatar image

Uggly Owliiver
23 4 6 12

(comments are locked)
10|2000 characters needed characters left

Thanks for pointing me in the right direction. I wanted to turn off the cursor completely (changing variables in Player Controller didn't help) and setting Cursor parameter to None solved it for me. But it looks like it need to be set like that for all elements of the widget. In your case I would check out if there are no more widgets active in the background which can have Cursor set to Default for example.

more ▼

answered Nov 11 '15 at 08:01 PM

avatar image

Nox_A15
294 18 136 193

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question