x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Swarm Agent Coordinator does not calculate lightmap itself

Hey all!

Currently I am trying some things with Swarm Agent. I've got it all working! So currently I am working on my pc and when I want to build the lightmaps it distributes it to my laptop. Problem is now, that only my laptop is calculating the lightmaps and my pc is just coordinating i guess. I have already tried setting up swarm coordinator on my laptop and build on my pc but has the same outcome.

Maybe the host in swarm agent cant help with building, I don't know but i can't find any information about that.

If anyone could clarify that for me or help me with a solution, I would be so thankful!

Product Version: Not Selected
Tags:
more ▼

asked Jan 06 '15 at 09:59 AM in Rendering

avatar image

Re1ntjuhH
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

You need to run Swarm Agent on all the computers you want to calculate - so if you want the coordinator computer to also build the lightmaps you need it to be running Swarm Agent along with the coordinator program. Hope this helps!

more ▼

answered Jan 07 '15 at 05:52 AM

avatar image

BarrettMeeker
59 3 7 12

avatar image Re1ntjuhH Jan 07 '15 at 07:37 PM

That's the weird thing, I've got all that..

So I am working on my PC in UE. Got the Coordinator and Swarm Agent active. My Laptop also has Swarm Agent on.

But when i start a build on my PC both the systems start working, until processing maps begins. Swarm Agent tells me my pc and laptop are both working on it, but when I watch my CPU or RAM it is'nt doing anything...

The weird thing is when the build completes, Swarm Agent changes, so instead of the different blue bars what it was showing before. It is now a blue stripe (vertical) so like my pc hasn't done anything for processing maps, which is correct.

Any solution?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So here I am building, it looks like both the laptop and pc are working. But in task manager u can see that it's practically doing nothing. alt text

When the build finishes even swarm agent finally makes up his mind.. alt text

Anyone experienced this before?

Thanks!

swarm_agent_01.png (321.7 kB)
swarm_agent_02.png (321.6 kB)
more ▼

answered Jan 07 '15 at 08:54 PM

avatar image

Re1ntjuhH
1 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try testing it with a level that is just made up of ~50 objects with 128 resolution light maps. It could be that the level your building has one very large lightmap and that is what is taking a long time - and it's not something that can be spread across multiple computers.

more ▼

answered Jan 08 '15 at 12:24 AM

avatar image

BarrettMeeker
59 3 7 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thanks for your response!

I've tried your suggestion! Sadly it still doesn't work. I've tried 50 models with 64 lightmap and 50 with 128 lightmap and still all the power has to come from my laptop =(

more ▼

answered Jan 08 '15 at 02:33 AM

avatar image

Re1ntjuhH
1 1 2 3

avatar image BarrettMeeker Jan 09 '15 at 10:31 PM

Hmmm ok one last idea... maybe the level your building builds quite quickly anyway and swarm isn't that good at splitting builds that are quick... (just a theory) It looks like from your images the build time is just a couple minutes, maybe try making a bigger level that takes 15+ minutes to build?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have te same problem, only i use 6 exta laptops and non of them get in het Processing mappings or only some time and than drops back. I have a very big scene, so last comment is not the issue.

more ▼

answered Oct 13 '15 at 10:02 AM

avatar image

E Bouwens
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question