x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sliding when using root motion

There are only a couple of my animations that have root motion built in - two examples are the aiming animations from high cover. The character pops out and it's useful to have root motion so the character actually moves out of cover.

This works correctly, however just afterwards something odd happens - the character, while holding the pose, slides backwards towards the old position. Why is this happening and how can I stop it?

You can see what's happening in this picture. the root as moved, but the orange line represents some sort of tether to the old position which pulls the character in.

alt text

Product Version: Not Selected
Tags:
capture.png (156.7 kB)
more ▼

asked Jan 06 '15 at 11:07 AM in Blueprint Scripting

avatar image

Asher S Einhorn
650 94 80 181

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

because your not using root motion, Your character is sliding back to where, your capsule is, that still didn't move. You have to enable root motion on the montage, and depending what version you are using, the animation BLueprint must also have it enabled.

-Also when you do get it to play, sometimes it doesn't want to work properly. I found a technique to get the root motion to fully work, is to set the movement to Flying. This makes sure all the animation will play without gravity affecting it. Hope this helps! Cheers :)

more ▼

answered Jan 07 '15 at 02:58 AM

avatar image

caelanim8ter
48 8 15 16

avatar image Asher S Einhorn Jan 13 '15 at 07:24 PM

This has helped to some degree, I no longer have the problem shown in the picture, the root successfully updates with the character. however the sliding still happens! I have no idea why!

avatar image Asher S Einhorn Jan 14 '15 at 09:49 AM

it seems the root is moving away from the capsule, but I have enabled root motion!

avatar image Asher S Einhorn Jan 14 '15 at 06:22 PM

Make sure you've set Root Motion Mode to Root Motion from Everything in the anim blueprint editor window in the graph tab of the animation blueprint. and make sure you select edit defaults and not edit preview at the top for this - easy to miss.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question