x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

P4 Merge Crashing

Hi AnswerHub!

So, my UE crashes when I try to use p4 as source control for files. used to work fine til I updated both the P4 client and 4.6.1 (can't figure out which did it, but i cannot seem to get around it.

Any ideas what could this be?

Product Version: Not Selected
Tags:
more ▼

asked Jan 07 '15 at 09:31 AM in Bug Reports

avatar image

ronaldk
75 12 18 22

avatar image Tom Sarkanen STAFF Jan 07 '15 at 03:27 PM

When does your editor crash? On startup or on connection to source control? Do you have a log file that you could post here?

avatar image ronaldk Jan 07 '15 at 08:00 PM

When i go to 'editor preferences/ Leading & Saving/ Source Control', It all goes fine. Then i check 'Use Glogal settings' and the window with the connection settings pops up but immediately UE crashes.

Also, if I just go through File/ Submit to Source Control' same thing happens. I submitted a crash report last night. alt text

crash.jpg (47.2 kB)
avatar image Tom Sarkanen STAFF Jan 08 '15 at 08:36 AM

Do you have a log file that shows what you were doing when the crash occurred? Log files are in [PROJECTDIR]/Saved/Logs.

avatar image ronaldk Jan 09 '15 at 11:30 PM

Hi, So,I just created a brand new project, chose to connect and crashed. latest version of Perforce and using UE4.6.1

How should i post the file? For now on dropbox..

avatar image ronaldk Jan 09 '15 at 11:41 PM

It's odd, just did same test on different pc and same result: new project, connect to source control, crash..

avatar image ronaldk Jan 10 '15 at 02:42 AM

reverted to previous working p4v, still crahing.

avatar image ronaldk Jan 10 '15 at 03:07 AM

Reverted also to 4.5 and still crashing. What is odd is that it's happening on 2 different computers. My "coworker" has the same versions i had earlier and can still connect and submit to my P4 server...

avatar image Tom Sarkanen STAFF Jan 12 '15 at 09:29 AM

Thanks for posting your logs, it gets us a little closer to the problem!

The crash isn't occurring inside the editor, rather it is failing with a stack overflow inside the windows networking system. Something inside ASProxy64.dll or WS2_32.dll is trying to allocate something large on the stack.

Very odd, as you say - as the crash looks like it may have something to do with your windows configuration it is strange that it would occur on two machines. I will try to unearth your crash report form our DB when it is back up (it is not working at present) and gather more information.

avatar image Tom Sarkanen STAFF Jan 13 '15 at 09:44 AM

Our crash reporter DB is now back up but is missing a few days worth of reports. Once these are back in place I will take another look to see if yours is there.

avatar image Tom Sarkanen STAFF Jan 15 '15 at 09:21 AM

Unfortunately I have not been able to retrieve the crash report shown above - it never ended up in our DB. The last thing I can suggest to help us diagnose your issue is to enable verbose logging before you enable source control in the editor. Open a console ('~' key usually) and type:

Log LogSourceControl verbose

If you then try to connect (and crash), the logs should contain some more information that could help us track the issue down. If you post them here that would be really helpful.

avatar image ronaldk Jan 15 '15 at 05:34 PM

Hi Tom, Thanks for your help. Unfortunately i have still not been able to resolve the issue. I tried uninstall/ reinstall with no success. I followed your suggestion and got the log after the crash. I also submitted the report with the description "Perforce crash".

I hope we can figure this out. we are desperate!

avatar image ronaldk Jan 17 '15 at 11:28 PM

It gets strange.. I was thinking there might be something wrong with compatibility on the server or maybe some perforce aspect but i installed p4 and ue4 on 2 remote pc's and they both work under my same server. only the 2 pc's inside the lan (one of which is the server) crash. Please help!

avatar image Tom Sarkanen STAFF Jan 19 '15 at 09:15 AM

We have found that the crash reports submitted to our DB did get through, but our system was unable to resolve the callstack's symbols, so we cannot get any more information from them. Have you built your own editor from source?

avatar image Tom Sarkanen STAFF Jan 19 '15 at 02:49 PM

I now finally have found your crash report and analyzed it, but unfortunately the dump does not include a valid callstack for the worker thread in question (probably because the stack is trashed by the stack overflow). I'm continuing investigations, but its not looking hopeful.

As we cannot reproduce the issue here, my only suggestion now would be to locally build the editor and attempt to reproduce the crash yourself. Hopefully this will yield a valid callstack that we can use to further investigate.

avatar image ronaldk Jan 19 '15 at 07:23 PM

i don't even know what that means =( Sorry. I have not built my own editor, i literally just updated and it somehow broke. I will try again to uninstall/ reinstall everything.. It's very strange that it broke on 2 pc's but continues to work on 2 others using the same server and versions of both software packages.

I will report back if anything happens.

avatar image ronaldk Jan 19 '15 at 10:59 PM

Hey, i may be getting closer to something, but im not sure.. I just realized a common thing with both pc's is that when the source control screen shows up, the username for perforce is wrong, making it crash.

I uninstalled p4 and I ran source control in ue4 and it ran fine (no crash, except it couldn't connect to p4). When i reinstalled it, it automatically set the username as the pc's name and not what was specified before, giving me an error to connect. I set the username as it's supposed to be and connected perfectly.

Ran Source control in UE4 and it was still showing as the pc's name and not the username, giving me a crash.

Now i need to find where to change the default username for p4 connection in ue4.. any idea how i may do this??

avatar image Tom Sarkanen STAFF Jan 20 '15 at 10:10 AM

We try to autodetect the connection from the current environment settings. You can set these in P4V under the "Connection->Environment Settings..." menu.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

After breaking my head with a group of people, none of which could figure this out, i decided to format my pc and reinstal windows (that desperate).

Did the updates, installed p4, installed UE4-- WORKS!!.. but now i was curious as to what was causing the crash.. so i went down the list of tools and software i had installed on my pc and finally found the culprit -- ASTRILL VPN!!! -- i had it installed on both computers where UE was crashing.

Installed Astrill, crash.. uninstalled.. worked again!

It didn't matter wether i had it on or off, just the fact it was installed was enough for the crash.

Is there a way I can fix this? (being able to have astrill on my pc and use UE4??)

more ▼

answered Jan 21 '15 at 10:41 AM

avatar image

ronaldk
75 12 18 22

avatar image Tom Sarkanen STAFF Jan 21 '15 at 01:34 PM

Perhaps you could contact Astrill for any tips on how to avoid this? They are likely hooking into some low-level windows systems. I will log an issue our side to track this!

avatar image ronaldk Jan 21 '15 at 06:14 PM

Thanks so much and thank you for your help either way.

I don't know if they will even get back to me as to even explain what my issue is, is complicated enough. It would be nice to be able to use Astrill without ue4 crashing though. ;) --but yeah, i can see this being lowest priority.

Cheers, and again, thanks for your time!! =)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question