x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4.5.1 Local Windows Debugger launch, doesnt build Program.

I have to Build program first manually, and only after that i can press Local Windows Debugger, otherwise it is not rebuild and not launch.

100% bug.

Product Version: Not Selected
Tags:
more ▼

asked Jan 07 '15 at 06:04 PM in Bug Reports

avatar image

newbprofi
1.1k 119 143 373

avatar image Tim C ♦♦ STAFF Jan 13 '15 at 09:24 PM

Hi newbprofi,

I tried to reproduce the issue that you described in 4.5.1, but was unable to do so. I have some clarification questions for you.

  • When you say you have to build the "program" manually, are you referring to building a project, or the Engine itself?

  • It sounds like you are trying to run within Visual Studio's debugging environment, correct? Are you clicking the Local Windows Debugger play button in the hotbar at the top of Visual Studio? Have you tried right-clicking on the project in the Solution Explorer and selecting Debug -> Start New Instance?

  • When you click the Local Windows Debugger button, do you see a popup window from Visual Studio stating that the project is out of date and asking if you would like to build it?

  • What happens when you click the Local Windows Debugger button?

Tim

avatar image newbprofi Jan 13 '15 at 10:48 PM
  • i refferring to build whole solution, with MyProgram set to startup project. And then, automatic build i mean - Press button "Local Windows Debugger" on top-left of Visual Studio 2013. Manual build - (RMB MyProgram)->Build/Debug, so RMB is like manual for me.

  • yes. No i didnt try, but it need to use RMB, so its manual(too hard) for me.

  • no i didnt see anything, i was just getting some errors in Output window, dont remember which exactly.

  • when i was change some code in MyProgram, and try to click "Local Windows Debugger", then its trying to run newly compiled program with old MyProgram.obj or smth like that, but i really dont remember.

When i am trying to reproduce this now, i cant, and everything is compiled fine when i change code and click "Local Windows Debugger", so i think the bug is hiding (not easy to reproduce). From this moment i will try to use "Local Windows Debugger" button, and if i see this bug again i will tell u more details.

PS: sry, didnt expect that its hard to reproduce. I wasnt use straightly "Local Windows Debugger" button from that moment, until now. I used instead "RMB MyProgram->Build", and only then click "Local Windows Debugger". But now i will use straightly "Local Windows Debugger" button, if i see bug again, i will tell.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi newbprofi,

I am glad to hear that this issue seems to have stopped occurring. If it pops up again, please let us know. I did want to double-check one thing, though. You mentioned that you do not see a pop-up window in Visual Studio when you click the Local Windows Debugger button. So you are not seeing this prompt at all?

Debug

Tim

debug.png (20.5 kB)
more ▼

answered Jan 20 '15 at 11:50 PM

avatar image newbprofi Jan 24 '15 at 01:05 AM

yes, i didnt see this. Otherwise that would be too simple. But anyway, i am used to use RMB + Build, because now i often only compile, instead of compile+run. I tryed to use Local Windows Debugger button for recompile+run couple of times, everything seems fine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question