x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.6.1] Can't make new projects

So launching the engine and attempting to start a new project, it runs through everything like normal but gets stuck on 90% and goes into not responding. When I close the engine and launcher, and re-open, the project shows up under My Projects but when I run it it says "MyProject.dll" needs to be compiled, and when I attempt to it just hangs forever. I've tried looking everywhere to see if anyone else has ran into this and I'm running into dead ends. If anyone can assist, I'd be grateful!

edit: So it seems I can make blueprint projects fine, but its any time I try to make a code project.

edit 2: Also, it does seem to specifically be 4.6.1, I finally finished my 4.5 download and was immediately able to make a code project, open, build, and run.

Product Version: Not Selected
Tags:
more ▼

asked Jan 10 '15 at 05:34 AM in Installation & Setup

avatar image

BenniKane
21 1 4 4

avatar image Doug E ♦♦ STAFF Jan 16 '15 at 04:38 PM

Hey BenniKane-

Does this hang up at 90% happen when building/opening the project from Visual Studio or does it happen before Visual Studio even opens? After closing and re-opening the Launcher/engine, does the project show up on your computer in the file location that you created it in? If the folder exists then one thing you could try would be to right click the .uproject file and select the "Generate Visual Studio project files" option to recreate the solution files for the project.

Cheers

Doug Wilson

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Cronk-

We're currently investigating the issue of users not being able to create code projects (UE-11475). For the time being you may want to use a blueprint project instead or try using another version of the engine if you want/need access to source code.

Cheers

Doug Wilson

more ▼

answered Mar 09 '15 at 05:35 PM

avatar image Cronk Mar 12 '15 at 02:15 PM

OK, I think I found the problem while trying to compile the GitHub version of UE4. The GenerateProjectFiles.bat could not generate any solution for the engine, but it gave me some useful output on the comandline: the problem was my PATH environment variable which, for some reason, contained quotation marks (something like "C:\Program Files (x86)\Java\jre7"). Removing the quotation marks did the trick. I could generate VisualStudio solution files for GitHub UE4, as well as for my own project. As far as I unterstood the wiki and the batch files output, UE4 is looking for SDKs for different platforms (eg Android) in the PATH environment variable, but does not properly escape the string. But that's more or less guessing. Sorry for my bad english. Cheers

avatar image Sonnyg007 Mar 14 '15 at 12:45 AM

Awesome. Ya I ended up doing the same thing as you. Went to compile from source and hit a dead end on GenerateProjectFiles.bat. Tracking down the output I found out I just had some trash left over in PATH as well as vcvarsx86_amd64.bat due to trying to fix a bug back when I was trying to build openssl. Thanks for the help. Got everything copacetic on my end.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi BenniKane,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Jan 21 '15 at 08:55 PM

avatar image Cronk Mar 06 '15 at 01:32 PM

Just found this post, as i am experiencing the exact same problem (UE4 4.7.2). The project actually shows up in the Launcher after reopening it and there's a bunch of files right where they belong on my disk. Assets, source files - everything's there, except the solution. Regenrating the solution did not come to an end after 2 hours. The log just has one line:

Running C:/Program Files/Unreal Engine/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="C:/Users/***/Documents/Unreal Projects/Proj/Proj.uproject" -game -rocket -progress

avatar image Cronk Mar 06 '15 at 03:23 PM

Just dowloaded UE4.4. Generation of a code project works like a charm. Once I try to convert it to 4.7, the process won't finish. Log:

Running C:/Program Files/Unreal Engine/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe ProjDevelopment Win64 -project="C:/Users/***/Documents/Unreal Projects/Proj/Proj.uproject" -rocket -editorrecompile -progress Parsing headers for ProjEditor Reflection code generated for ProjEditor

avatar image Doug E ♦♦ STAFF Mar 06 '15 at 08:57 PM

Hey Cronk-

In the Launcher click the drop down arrow next to the engine version and select Verify. If you are still getting errors when trying to create a project you can try uninstalling / re-installing 4.7.2.

avatar image Cronk Mar 07 '15 at 04:12 PM

Could have thought of that myself. Sadly, it did not work. Same result as before.

avatar image Doug E ♦♦ STAFF Mar 07 '15 at 11:03 PM

Are you using a source code build of the engine from GitHub or are you using the binary Launcher version? If you are using the Launcher, can you create a project if you bypass the launcher by opening the editor's .exe file directly?

avatar image Cronk Mar 08 '15 at 01:26 PM

I'm using the binary Launcher version. Launching the editor's .exe directly still leads to a never ending "Creating project... 90%". I will try building the engine from GitHub

avatar image Sonnyg007 Mar 12 '15 at 02:14 AM

I'm also having the same issue. Using the binary launcher, creating a new project worked fine (UE4 4.7.2). The editor crashed when I tried adding a blank c++ class. Restarted the editor and opened the project. Got an error stating "The following modules are missing or built with a different engine version" UE4Editor-, Would you like to rebuild them now?.

I hit Yes and get the build progress bar. It gets stuck at 0%. log says Running G:/Development/Unreal Engine/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe ProjectWolf2 Development Win64 -project="G:/Development/Unreal Projects/ProjectWolf2/ProjectWolf2.uproject" -rocket -editorrecompile -progress

It stays at this state indefinitely. Once I hit cancel it says to try compiling the source manually.

running win7x64 sp1

avatar image Cronk Mar 13 '15 at 02:40 PM

Did you try editing your PATH as I pointed out? Can you post the contents of your PATH environment variable?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question